Skip to content
Laskyr

Plugins · admin-custom-login · data as of 2026-11-04

Is Admin Custom Login safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.6.8)

As of 2026-11-04. 2 issues are on record for older versions; version 3.6.5 or newer fixes all of them that state a fix.

Latest version
3.6.8
Last updated
2026-09-11
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Customize Your WordPress Login Screen Amazingly - Add Own Logo, Add Social Profiles, Login Form Positions, Background Image Slide Show — by Weblizar - WordPress Themes & Plugin

What to do

  1. Update to the latest version (3.6.8). Anything older than 3.6.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get admin-custom-login --field=version shows what you run; wp plugin update admin-custom-login updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-2487 · published 2026-08-16

Stored cross-site scripting (XSS) in Admin Custom Login (3.6.4 and older)

Affected
3.6.4 and older
Fixed in
3.6.5 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Admin Custom Login plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.6.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-2487Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2021-34628 · published 2021-08-02

Cross-site request forgery (CSRF) in Admin Custom Login (3.2.7 to 3.2.7)

Affected
3.2.7 to 3.2.7
Fixed in
3.2.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Admin Custom Login WordPress plugin is vulnerable to Cross-Site Request Forgery due to the loginbgSave action found in the ~/includes/Login-form-setting/Login-form-background.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 3.2.7.

NVD CVE-2021-34628Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Admin Custom Login vulnerability status badge
<a href="https://laskyr.com/plugins/admin-custom-login"><img src="https://laskyr.com/plugins/admin-custom-login/badge.svg" alt="Admin Custom Login vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit