Skip to content
Laskyr

Plugins · admin-chat-box · data as of 2026-11-04

Is Admin Chat Management safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.2)

As of 2026-11-04. 1 issue is on record for older versions; version 3.1.2 or newer fixes all of them that state a fix.

Latest version
3.1.2
Last updated
2026-06-01
Active installs
fewer than 10
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Admin Firebase Support & Chat Management tool with real-time communication for WordPress. — by Sabbir Sam

What to do

  1. Update to the latest version (3.1.2). Anything older than 3.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get admin-chat-box --field=version shows what you run; wp plugin update admin-chat-box updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-8787 · published 2026-05-27

Privilege escalation in Admin Chat Management (3.1.1 and older)

Affected
3.1.1 and older
Fixed in
3.1.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by Wordfence
Details from the advisory

The Firebase Support & Chat Management plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 3.1.1. This is due to the `firebase_auth()` function authenticating the request as the WordPress user whose email is supplied in the `user_email` POST parameter without verifying ownership of that email (no Firebase ID token signature/issuer/audience verification). This makes it possible for authenticated attackers, with Subscriber-level access and above, to log in as an arbitrary existing user — including an Administrator — by submitting that user's email address to the `acb_firebase_auth` AJAX action, resulting in full account takeover.

NVD CVE-2026-8787Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Admin Chat Management vulnerability status badge
<a href="https://laskyr.com/plugins/admin-chat-box"><img src="https://laskyr.com/plugins/admin-chat-box/badge.svg" alt="Admin Chat Management vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit