Skip to content
Laskyr

Plugins · admin-and-client-message-after-order-for-woocommerce · data as of 2026-11-04

Is OrderConvo safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (15.1)

As of 2026-11-04. 4 issues are on record for older versions; version 15.0 or newer fixes all of them that state a fix.

Latest version
15.1
Last updated
2026-07-28
Active installs
200+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.2+

OrderConvo: Enable seamless post-order communication between vendors/admins and customers in WooCommerce. — by N-Media

What to do

  1. Update to the latest version (15.1). Anything older than 15.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get admin-and-client-message-after-order-for-woocommerce --field=version shows what you run; wp plugin update admin-and-client-message-after-order-for-woocommerce updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-13389 · published 2025-11-25

Missing authorization check in OrderConvo (14 and older)

Affected
14 and older
Fixed in
15.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Admin and Customer Messages After Order for WooCommerce: OrderConvo plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the `get_order_by_id()` function in all versions up to, and including, 14. This makes it possible for unauthenticated attackers to view sensitive WooCommerce order details and private conversation messages between customers and store administrators for any order by supplying an arbitrary order ID.

NVD CVE-2025-13389Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-13452 · published 2025-11-25

Missing authorization check in OrderConvo (14 and older)

Affected
14 and older
Fixed in
15.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Admin and Customer Messages After Order for WooCommerce: OrderConvo plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 14. This is due to a flawed permission check in the REST API permission callback that returns true when no nonce is provided. This makes it possible for unauthenticated attackers to impersonate any WordPress user and inject arbitrary messages into any WooCommerce order conversation by directly calling the REST endpoint with controlled user_id, order_id, and context parameters.

NVD CVE-2025-13452Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-13355 · published 2025-01-16

Cross-site scripting (XSS) in OrderConvo (13.2 and older)

Affected
13.2 and older
Fixed in
13.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Admin and Customer Messages After Order for WooCommerce: OrderConvo plugin for WordPress is vulnerable to limited file uploads due to insufficient file type validation in the upload_file() function in all versions up to, and including, 13.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload files on the affected site's server which may make remote code execution possible and is confirmed to make Cross-Site Scripting possible.

NVD CVE-2024-13355Wordfence advisoryCode change (fix)

critical 10.0 CVE-2024-33566 · published 2024-04-29

Missing authorization check in OrderConvo (12.4 and older)

Affected
12.4 and older
Fixed in
12.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in N-Media OrderConvo allows OS Command Injection.This issue affects OrderConvo: from n/a through 12.4.

NVD CVE-2024-33566Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
OrderConvo vulnerability status badge
<a href="https://laskyr.com/plugins/admin-and-client-message-after-order-for-woocommerce"><img src="https://laskyr.com/plugins/admin-and-client-message-after-order-for-woocommerce/badge.svg" alt="OrderConvo vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit