Skip to content
Laskyr

Plugins · adirectory · data as of 2026-11-04

Is aDirectory safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.6)

As of 2026-11-04. 3 issues are on record for older versions; version 3.0.4 or newer fixes all of them that state a fix.

Latest version
3.1.6
Last updated
2026-04-06
Active installs
300+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

aDirectory is a lightweight, scalable, fast WordPress directory plugin for building any type of directories, classifieds, and job boards websites. — by aDirectory

What to do

  1. Update to the latest version (3.1.6). Anything older than 3.0.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get adirectory --field=version shows what you run; wp plugin update adirectory updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-67975 · published 2026-02-20

Missing authorization check in aDirectory (3.0.3 and older)

Affected
3.0.3 and older
Fixed in
3.0.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in aDirectory aDirectory adirectory allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects aDirectory: from n/a through <= 3.0.3.

NVD CVE-2025-67975Patchstack advisory

medium 5.4 CVE-2024-13541 · published 2025-02-12

Missing authorization check in aDirectory (2.3 and older)

Affected
2.3 and older
Fixed in
2.3.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The aDirectory – WordPress Directory Listing Plugin plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the adqs_delete_listing() function in all versions up to, and including, 2.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary posts.

NVD CVE-2024-13541Wordfence advisoryCode change (fix)Plugin source

critical 10.0 CVE-2024-50420 · published 2024-10-29

Arbitrary file upload in aDirectory (1.3 and older)

Affected
1.3 and older
Fixed in
1.3.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in aDirectory aDirectory adirectory allows Upload a Web Shell to a Web Server.This issue affects aDirectory: from n/a through <= 1.3.

NVD CVE-2024-50420Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
aDirectory vulnerability status badge
<a href="https://laskyr.com/plugins/adirectory"><img src="https://laskyr.com/plugins/adirectory/badge.svg" alt="aDirectory vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit