Skip to content
Laskyr

Plugins · addons-for-divi · data as of 2026-11-04

Is Divi Torque Lite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.15.0)

As of 2026-11-04. 3 issues are on record for older versions; version 4.3.0 or newer fixes all of them that state a fix.

Latest version
4.15.0
Last updated
2026-11-01
Active installs
50,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

41 free Divi 5 modules and Divi extensions: image carousel, logo carousel, accordion, tabs, modal popup, video popup, FAQ, and more. — by Fahim Reza

What to do

  1. Update to the latest version (4.15.0). Anything older than 4.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get addons-for-divi --field=version shows what you run; wp plugin update addons-for-divi updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-4275 · published 2026-07-09

Cross-site request forgery (CSRF) in Divi Torque Lite (4.2.3 and older)

Affected
4.2.3 and older
Fixed in
4.3.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Divi Torque Lite – Divi Theme, Divi Builder & Extra Theme plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.2.3. This is due to the use of '__return_true' as the permission_callback for the /install_plugin and /activate_plugin REST API endpoints, which bypasses WordPress's built-in REST API nonce verification. Although the endpoint callbacks contain internal current_user_can() checks, the absence of nonce verification means that a forged cross-site request from a logged-in administrator's browser will pass the capability check via the admin's session cookies. This makes it possible for unauthenticated attackers to install arbitrary plugins from WordPress.

NVD CVE-2026-4275Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2025-0353 · published 2025-01-29

Stored cross-site scripting (XSS) in Divi Torque Lite (4.1.0 and older)

Affected
4.1.0 and older
Fixed in
4.1.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Divi Torque Lite – Best Divi Addon, Extensions, Modules & Social Modules plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several widgets in all versions up to, and including, 4.1.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-0353Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 6.4 CVE-2024-5892 · published 2024-06-12

Stored cross-site scripting (XSS) in Divi Torque Lite (3.6.6 and older)

Affected
3.6.6 and older
Fixed in
4.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Divi Torque Lite – Divi Theme and Extra Theme plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘support_unfiltered_files_upload’ function in all versions up to, and including, 3.6.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5892Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Divi Torque Lite vulnerability status badge
<a href="https://laskyr.com/plugins/addons-for-divi"><img src="https://laskyr.com/plugins/addons-for-divi/badge.svg" alt="Divi Torque Lite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit