Skip to content
Laskyr

Plugins · addonify-quick-view · data as of 2026-11-04

Is Addonify safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.6)

As of 2026-11-04. 2 issues are on record for older versions; version 2.0.5 or newer fixes all of them that state a fix.

Latest version
2.0.6
Last updated
2026-07-16
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Addonify WooCommerce Quick View plugin adds functionality to have a quick preview of WooCommerce product on a popup modal. — by Addonify

What to do

  1. Update to the latest version (2.0.6). Anything older than 2.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get addonify-quick-view --field=version shows what you run; wp plugin update addonify-quick-view updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-68578 · published 2025-12-24

Missing authorization check in Addonify (2.0.4 and older)

Affected
2.0.4 and older
Fixed in
2.0.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Addonify Addonify addonify-quick-view allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Addonify: from n/a through <= 2.0.4.

NVD CVE-2025-68578Patchstack advisory

medium 5.3 CVE-2024-6560 · published 2024-07-20

Information disclosure in Addonify (1.2.16 and older)

Affected
1.2.16 and older
Fixed in
1.2.17 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Addonify – Quick View For WooCommerce plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 1.2.16. This is due the plugin utilizing mobiledetect without preventing direct access to the files. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.

NVD CVE-2024-6560Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Addonify vulnerability status badge
<a href="https://laskyr.com/plugins/addonify-quick-view"><img src="https://laskyr.com/plugins/addonify-quick-view/badge.svg" alt="Addonify vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit