Skip to content
Laskyr

Plugins · additional-product-fields-for-woocommerce · data as of 2026-11-04

Is Extra Product Options Builder for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.179)

As of 2026-11-04. 4 issues are on record for older versions; version 1.2.176 or newer fixes all of them that state a fix.

Latest version
1.2.179
Last updated
2026-10-15
Active installs
1,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

The most customizable extra product options builder for WooCommerce. You will love how many fields and features the free version has. — by EDGARROJAS

What to do

  1. Update to the latest version (1.2.179). Anything older than 1.2.176 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get additional-product-fields-for-woocommerce --field=version shows what you run; wp plugin update additional-product-fields-for-woocommerce updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-19728 · published 2026-08-16

Missing authorization check in Extra Product Options Builder for WooCommerce (older than 1.2.176)

Affected
older than 1.2.176
Fixed in
1.2.176
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Extra Product Options Builder for WooCommerce WordPress plugin before 1.2.176 does not verify that the requester is entitled to a customer-uploaded file before serving it, allowing unauthenticated users who obtain a file's stored name to retrieve it. The Extra Product Options Builder for WooCommerce WordPress plugin before 1.2.176 writes a deny-all rule into its upload directories, so the disclosure only crosses a boundary on web servers that honour it, such as Apache. Where it is ignored, as on a default nginx setup, the same files are already served at their direct URL and the endpoint exposes nothing further.

NVD CVE-2026-19728WPScan advisory

medium 6.5 CVE-2026-57390 · published 2026-07-13

Missing authorization check in Extra Product Options Builder for WooCommerce (1.2.167 and older)

Affected
1.2.167 and older
Fixed in
1.2.168
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in EDGARROJAS Extra Product Options Builder for WooCommerce additional-product-fields-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Extra Product Options Builder for WooCommerce: from n/a through <= 1.2.167.

NVD CVE-2026-57390Patchstack advisory

medium 6.1 CVE-2024-9214 · published 2024-10-24

Stored cross-site scripting (XSS) in Extra Product Options Builder for WooCommerce (1.2.133 and older)

Affected
1.2.133 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Extra Product Options Builder for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'RednaoSerializedFields' parameter during the creation of a signature file in all versions up to, and including, 1.2.133 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-9214Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2024-31940 · published 2024-04-15

Cross-site request forgery (CSRF) in Extra Product Options Builder for WooCommerce (1.2.104 and older)

Affected
1.2.104 and older
Fixed in
1.2.105
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in RedNao Extra Product Options Builder for WooCommerce.This issue affects Extra Product Options Builder for WooCommerce: from n/a through 1.2.104.

NVD CVE-2024-31940Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Extra Product Options Builder for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/additional-product-fields-for-woocommerce"><img src="https://laskyr.com/plugins/additional-product-fields-for-woocommerce/badge.svg" alt="Extra Product Options Builder for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit