Plugins · additional-order-filters-for-woocommerce · data as of 2026-11-04
Is Additional Order Filters for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 1.24
- Last updated
- 2025-12-09
- Active installs
- 2,000+
- Known issues on record
- 4
- Unpatched in latest
- 1
- Tested up to WP
- 6.9.11 · PHP 7.0+
Do you have a large WooCommerce store with hunderd or thousands orders? Then this plugin created for you. — by Anton Bond
What to do
- There is no fixed version yet. If you can live without Additional Order Filters for WooCommerce for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get additional-order-filters-for-woocommerce --field=version shows what you run; wp plugin update additional-order-filters-for-woocommerce updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 affects latest 1.24 CVE-2026-39800 · published 2026-10-10
Cross-site scripting (XSS) in Additional Order Filters for WooCommerce (1.24 and older)
- Affected
- 1.24 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Additional Order Filters for WooCommerce <= 1.24 versions.
high 7.1 CVE-2025-53271 · published 2025-06-27
Cross-site request forgery (CSRF) in Additional Order Filters for WooCommerce (1.22 and older)
- Affected
- 1.22 and older
- Fixed in
- 1.23
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Anton Bond Additional Order Filters for WooCommerce additional-order-filters-for-woocommerce allows Stored XSS.This issue affects Additional Order Filters for WooCommerce: from n/a through <= 1.22.
medium 6.1 CVE-2024-11418 · published 2024-11-26
Reflected cross-site scripting (XSS) in Additional Order Filters for WooCommerce (1.21 and older)
- Affected
- 1.21 and older
- Fixed in
- 1.22 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Additional Order Filters for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'shipping_method_filter' parameter in all versions up to, and including, 1.21 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
medium 6.1 CVE-2023-47690 · published 2023-11-13
Reflected cross-site scripting (XSS) in Additional Order Filters for WooCommerce (1.10 and older)
- Affected
- 1.10 and older
- Fixed in
- 1.11 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Anton Bond Additional Order Filters for WooCommerce plugin <= 1.10 versions.
Recent activity
- 2025-12-09 — latest release on wordpress.org (1.24).
- 2026-10-10 — Cross-site scripting (XSS) disclosed (CVE-2026-39800), no fix listed yet.
- 2025-06-27 — Cross-site request forgery (CSRF) disclosed (CVE-2025-53271), fixed in 1.23.
- 2024-11-26 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-11418), fixed in 1.22.
Get an email when Additional Order Filters for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Additional Order Filters for WooCommerce (additional-order-filters-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/additional-order-filters-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/additional-order-filters-for-woocommerce"><img src="https://laskyr.com/plugins/additional-order-filters-for-woocommerce/badge.svg" alt="Additional Order Filters for WooCommerce vulnerability status"></a>