Plugins · addfunc-head-footer-code · data as of 2026-11-04
Is AddFunc Head & Footer Code safe? Known vulnerabilities and latest version
- Latest version
- 2.5
- Last updated
- 2026-04-22
- Active installs
- 20,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
Easily add code to your head, footer and/or immediately after the opening body tag, site-wide and/or on any individual page/post. — by AddFunc
What to do
- Update to the latest version (2.5). Anything older than 2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get addfunc-head-footer-code --field=version shows what you run; wp plugin update addfunc-head-footer-code updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-2305 · published 2026-04-10
Stored cross-site scripting (XSS) in AddFunc Head & Footer Code (2.3 and older)
- Affected
- 2.3 and older
- Fixed in
- 2.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The AddFunc Head & Footer Code plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `aFhfc_head_code`, `aFhfc_body_code`, and `aFhfc_footer_code` post meta values in all versions up to, and including, 2.3. This is due to the plugin outputting these meta values without any sanitization or escaping. While the plugin restricts its own metabox and save handler to administrators via `current_user_can('manage_options')`, it does not use `register_meta()` with an `auth_callback` to protect these meta keys. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts via the WordPress Custom Fields interface that execute when an administrator previews or views the post.
NVD CVE-2026-2305Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-04-22 — latest release on wordpress.org (2.5).
- 2026-04-10 — Stored cross-site scripting (XSS) disclosed (CVE-2026-2305), fixed in 2.4.
Get an email when AddFunc Head & Footer Code has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for AddFunc Head & Footer Code (addfunc-head-footer-code) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/addfunc-head-footer-code (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/addfunc-head-footer-code"><img src="https://laskyr.com/plugins/addfunc-head-footer-code/badge.svg" alt="AddFunc Head & Footer Code vulnerability status"></a>