Skip to content
Laskyr

Plugins · add-to-any · data as of 2026-11-01

Is AddToAny Share Buttons safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.18)

As of 2026-11-01. 2 issues are on record for older versions; version 1.7.48 or newer fixes all of them that state a fix.

Latest version
1.8.18
Last updated
2026-05-22
Active installs
300,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.6+

Share buttons for WordPress including the AddToAny button, Facebook, Bluesky, Mastodon, WhatsApp, Pinterest, Reddit, many more, and follow icons too. — by micropat

What to do

  1. Update to the latest version (1.8.18). Anything older than 1.7.48 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get add-to-any --field=version shows what you run; wp plugin update add-to-any updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.8 CVE-2021-24616 · published 2021-11-08

Cross-site scripting (XSS) in AddToAny Share Buttons (older than 1.7.48)

Affected
older than 1.7.48
Fixed in
1.7.48
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The AddToAny Share Buttons WordPress plugin before 1.7.48 does not escape its Image URL button setting, which could lead allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

NVD CVE-2021-24616WPScan advisoryCode change (fix)

medium 5.4 CVE-2021-24568 · published 2021-09-06

Cross-site scripting (XSS) in AddToAny Share Buttons (older than 1.7.46)

Affected
older than 1.7.46
Fixed in
1.7.46
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The AddToAny Share Buttons WordPress plugin before 1.7.46 does not sanitise its Sharing Header setting when outputting it in frontend pages, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed

NVD CVE-2021-24568WPScan advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
AddToAny Share Buttons vulnerability status badge
<a href="https://laskyr.com/plugins/add-to-any"><img src="https://laskyr.com/plugins/add-to-any/badge.svg" alt="AddToAny Share Buttons vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit