Skip to content
Laskyr

Plugins · add-multiple-marker · data as of 2026-11-04

Is Multi Location Marker safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3)

As of 2026-11-04. 2 issues are on record for older versions; version 1.3 or newer fixes all of them that state a fix.

Latest version
1.3
Last updated
2026-01-06
Active installs
80+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 8.2+

Multi Location Marker helps you add multiple map locations to a single map and display them on the frontend using a shortcode. — by KrishaWeb

What to do

  1. Update to the latest version (1.3). Anything older than 1.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get add-multiple-marker --field=version shows what you run; wp plugin update add-multiple-marker updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-11999 · published 2025-11-11

Missing authorization check in Multi Location Marker (1.2 and older)

Affected
1.2 and older
Fixed in
1.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Add Multiple Marker plugin for WordPress is vulnerable to unauthorized modification of data to due to a missing capability check on the addmultiplemarker_reset_map() and amm_save_map_api() functions in all versions up to, and including, 1.2. This makes it possible for unauthenticated attackers to update the map API and reset maps.

NVD CVE-2025-11999Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2022-45080 · published 2023-04-23

Cross-site request forgery (CSRF) in Multi Location Marker (1.2 and older)

Affected
1.2 and older
Fixed in
1.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in KrishaWeb Add Multiple Marker plugin <= 1.2 versions.

NVD CVE-2022-45080Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Multi Location Marker vulnerability status badge
<a href="https://laskyr.com/plugins/add-multiple-marker"><img src="https://laskyr.com/plugins/add-multiple-marker/badge.svg" alt="Multi Location Marker vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit