Skip to content
Laskyr

Plugins · ad-sliding-faq · data as of 2026-11-04

Is AD Sliding FAQ safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5)

As of 2026-11-04. 1 issue is on record for older versions; version 2.5 or newer fixes all of them that state a fix.

Latest version
2.5
Last updated
2026-04-14
Active installs
20+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11

Create a nice and accessible accordion FAQ section with sliding Q/A. — by Thomas Villain

What to do

  1. Update to the latest version (2.5). Anything older than 2.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ad-sliding-faq --field=version shows what you run; wp plugin update ad-sliding-faq updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-14122 · published 2026-01-07

Stored cross-site scripting (XSS) in AD Sliding FAQ (2.4 and older)

Affected
2.4 and older
Fixed in
2.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The AD Sliding FAQ plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'sliding_faq' shortcode in all versions up to, and including, 2.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-14122Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
AD Sliding FAQ vulnerability status badge
<a href="https://laskyr.com/plugins/ad-sliding-faq"><img src="https://laskyr.com/plugins/ad-sliding-faq/badge.svg" alt="AD Sliding FAQ vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit