Skip to content
Laskyr

Plugins · ad-invalid-click-protector · data as of 2026-11-04

Is Ad Invalid Click Protector (AICP) safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.2)

As of 2026-11-04. 3 issues are on record for older versions; version 1.3.1 or newer fixes all of them that state a fix.

Latest version
1.3.2
Last updated
2026-07-20
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

One plugin to save your AdSense account from Click Bombings and Invalid Click Activities — by iSaumya

What to do

  1. Update to the latest version (1.3.2). Anything older than 1.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ad-invalid-click-protector --field=version shows what you run; wp plugin update ad-invalid-click-protector updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-65445 · published 2026-07-27

Missing authorization check in Ad Invalid Click Protector (AICP) (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Ad Invalid Click Protector (AICP) <= 1.3.0 versions.

NVD CVE-2026-65445Patchstack advisory

medium 6.5 CVE-2022-0191 · published 2022-05-02

Cross-site request forgery (CSRF) in Ad Invalid Click Protector (AICP) (older than 1.2.7)

Affected
older than 1.2.7
Fixed in
1.2.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The Ad Invalid Click Protector (AICP) WordPress plugin before 1.2.7 does not have CSRF check deleting banned users, which could allow attackers to make a logged in admin remove arbitrary bans

NVD CVE-2022-0191WPScan advisoryCode change (fix)

high 8.8 CVE-2022-0190 · published 2022-02-14

SQL injection in Ad Invalid Click Protector (AICP) (older than 1.2.6)

Affected
older than 1.2.6
Fixed in
1.2.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
NVD analysis · score by NVD
Details from the advisory

The Ad Invalid Click Protector (AICP) WordPress plugin before 1.2.6 is affected by a SQL Injection in the id parameter of the delete action.

NVD CVE-2022-0190WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Ad Invalid Click Protector (AICP) vulnerability status badge
<a href="https://laskyr.com/plugins/ad-invalid-click-protector"><img src="https://laskyr.com/plugins/ad-invalid-click-protector/badge.svg" alt="Ad Invalid Click Protector (AICP) vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit