Skip to content
Laskyr

Plugins · acychecker · data as of 2026-11-04

Is Anti Spam and list cleaner safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.0.1 or newer fixes all of them that state a fix.

Latest version
2.0.1
Last updated
2026-07-27
Active installs
400+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Block fake accounts and delete users using a fake email address — by AcyMailing Newsletter Team

What to do

  1. Update to the latest version (2.0.1). Anything older than 2.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get acychecker --field=version shows what you run; wp plugin update acychecker updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.3 CVE-2026-66689 · published 2026-08-13

Missing authorization check in Anti Spam and list cleaner (2.0.0 and older)

Affected
2.0.0 and older
Fixed in
2.0.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Anti Spam and list cleaner &#8211; AcyChecker <= 2.0.0 versions.

NVD CVE-2026-66689Patchstack advisory

medium 6.5 CVE-2026-65448 · published 2026-07-27

Cross-site scripting (XSS) in Anti Spam and list cleaner (1.8.1 and older)

Affected
1.8.1 and older
Fixed in
2.0.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Anti Spam and list cleaner &#8211; AcyChecker <= 1.8.1 versions.

NVD CVE-2026-65448Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Anti Spam and list cleaner vulnerability status badge
<a href="https://laskyr.com/plugins/acychecker"><img src="https://laskyr.com/plugins/acychecker/badge.svg" alt="Anti Spam and list cleaner vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit