Plugins · actionwear-products-sync · data as of 2026-11-04
Is Actionwear products sync safe? Known vulnerabilities and latest version
- Latest version
- 3.1.16
- Last updated
- 2026-09-18
- Active installs
- 50+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Aggiungi e sincronizza i prodotti di ActionWear sul tuo WooCommerce — by marcoingraiti
What to do
- Update to the latest version (3.1.16). Anything older than 3.1.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get actionwear-products-sync --field=version shows what you run; wp plugin update actionwear-products-sync updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-49350 · published 2025-12-09
Missing authorization check in Actionwear products sync (2.3.3 and older)
- Affected
- 2.3.3 and older
- Fixed in
- 3.1.13 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in marcoingraiti Actionwear products sync actionwear-products-sync allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Actionwear products sync: from n/a through <= 2.3.3.
high 8.5 CVE-2025-31619 · published 2025-04-01
SQL injection in Actionwear products sync (2.3.3 and older)
- Affected
- 2.3.3 and older
- Fixed in
- 3.1.13 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in marcoingraiti Actionwear products sync actionwear-products-sync allows SQL Injection.This issue affects Actionwear products sync: from n/a through <= 2.3.3.
medium 5.3 CVE-2024-13535 · published 2025-02-18
Path traversal / file read in Actionwear products sync (2.3.2 and older)
- Affected
- 2.3.2 and older
- Fixed in
- 2.3.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Actionwear products sync plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 2.3.2. This is due the composer-setup.php file being publicly accessible with 'display_errors' set to true. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.
Recent activity
- 2026-09-18 — latest release on wordpress.org (3.1.16).
- 2025-12-09 — Missing authorization check disclosed (CVE-2025-49350), fixed in 3.1.13.
- 2025-04-01 — SQL injection disclosed (CVE-2025-31619), fixed in 3.1.13.
- 2025-02-18 — Path traversal / file read disclosed (CVE-2024-13535), fixed in 2.3.3.
Get an email when Actionwear products sync has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Actionwear products sync (actionwear-products-sync) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · SQL injection (1) · Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/actionwear-products-sync (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/actionwear-products-sync"><img src="https://laskyr.com/plugins/actionwear-products-sync/badge.svg" alt="Actionwear products sync vulnerability status"></a>