Skip to content
Laskyr

Plugins · accordions-wp · data as of 2026-11-04

Is Accordions safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.1)

As of 2026-11-04. 4 issues are on record for older versions; version 3.0.7 or newer fixes all of them that state a fix.

Latest version
4.0.1
Last updated
2026-10-24
Active installs
1,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Responsive, lightweight, and fully customizable accordion plugin for WordPress. Perfect for FAQs, content organization, and improving user experience. — by Themepoints

What to do

  1. Update to the latest version (4.0.1). Anything older than 3.0.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get accordions-wp --field=version shows what you run; wp plugin update accordions-wp updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-66471 · published 2026-08-13

Cross-site scripting (XSS) in Accordions (3.0.6 and older)

Affected
3.0.6 and older
Fixed in
3.0.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Cross Site Scripting (XSS) in Accordion <= 3.0.6 versions.

NVD CVE-2026-66471Patchstack advisory

medium 5.9 CVE-2025-69350 · published 2026-01-06

Stored cross-site scripting (XSS) in Accordions (3.0.3 and older)

Affected
3.0.3 and older
Fixed in
3.0.4
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themepoints Accordion accordions-wp allows Stored XSS.This issue affects Accordion: from n/a through <= 3.0.3.

NVD CVE-2025-69350Patchstack advisory

medium 5.4 CVE-2023-47809 · published 2023-11-22

Cross-site scripting (XSS) in Accordions (2.6 and older)

Affected
2.6 and older
Fixed in
2.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themepoints Accordion plugin <= 2.6 versions.

NVD CVE-2023-47809Patchstack advisory

medium 5.4 CVE-2023-5666 · published 2023-10-30

Stored cross-site scripting (XSS) in Accordions (2.6 and older)

Affected
2.6 and older
Fixed in
2.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Accordion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'tcpaccordion' shortcode in all versions up to, and including, 2.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-5666Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Accordions vulnerability status badge
<a href="https://laskyr.com/plugins/accordions-wp"><img src="https://laskyr.com/plugins/accordions-wp/badge.svg" alt="Accordions vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit