Plugins · accordions · data as of 2026-11-04
Is Accordions safe? Known vulnerabilities and latest version
- Latest version
- 2.3.25
- Last updated
- 2026-06-08
- Active installs
- 20,000+
- Known issues on record
- 8
- Unpatched in latest
- 1
- Tested up to WP
- 7.0.8
Create sleek accordions, tabs, FAQs, and image accordions with a React builder featuring advanced styling, animations, OpenAI support, and customizati … — by PickPlugins
What to do
- There is no fixed version yet. If you can live without Accordions for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get accordions --field=version shows what you run; wp plugin update accordions updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 affects latest 2.3.25 CVE-2026-116392 · published 2026-10-28
PHP object injection in Accordions (2.3.25 and older)
- Affected
- 2.3.25 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in PickPlugins Accordion accordions allows Object Injection.This issue affects Accordion: from n/a through 2.3.25.
medium 6.4 CVE-2026-10862 · published 2026-06-09
Stored cross-site scripting (XSS) in Accordions (2.3.23 and older)
- Affected
- 2.3.23 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Accordions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Accordion body field in all versions up to, and including, 2.3.23 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 6.5 CVE-2025-53421 · published 2025-10-22
Missing authorization check in Accordions (2.3.14 and older)
- Affected
- 2.3.14 and older
- Fixed in
- 2.3.16
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in PickPlugins Accordion accordions allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Accordion: from n/a through <= 2.3.14.
medium 6.5 CVE-2025-58678 · published 2025-09-22
Missing authorization check in Accordions (2.3.15 and older)
- Affected
- 2.3.15 and older
- Fixed in
- 2.3.16
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in PickPlugins Accordion accordions allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Accordion: from n/a through <= 2.3.15.
high 8.8 CVE-2025-32143 · published 2025-04-11
PHP object injection in Accordions (2.3.11 and older)
- Affected
- 2.3.11 and older
- Fixed in
- 2.3.12
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in PickPlugins Accordion accordions allows Object Injection.This issue affects Accordion: from n/a through <= 2.3.11.
medium 6.5 CVE-2024-47342 · published 2024-10-06
Stored cross-site scripting (XSS) in Accordions (2.2.99 and older)
- Affected
- 2.2.99 and older
- Fixed in
- 2.2.100
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PickPlugins Accordion accordions allows Stored XSS.This issue affects Accordion: from n/a through <= 2.2.99.
medium 5.4 CVE-2024-1641 · published 2024-04-09
Missing authorization check in Accordions (2.2.96 and older)
- Affected
- 2.2.96 and older
- Fixed in
- 2.2.97 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Accordion plugin for WordPress is vulnerable to unauthorized access of data and modification of data due to a missing capability check on the 'accordions_duplicate_post_as_draft' function in all versions up to, and including, 2.2.96. This makes it possible for authenticated attackers, with contributor access and above, to duplicate arbitrary posts, allowing access to the contents of password-protected posts.
NVD CVE-2024-1641Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2020-13644 · published 2020-05-28
Cross-site scripting (XSS) in Accordions (older than 2.2.9)
- Affected
- older than 2.2.9
- Fixed in
- 2.2.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
An issue was discovered in the Accordion plugin before 2.2.9 for WordPress. The unprotected AJAX wp_ajax_accordions_ajax_import_json action allowed any authenticated user with Subscriber or higher permissions the ability to import a new accordion and inject malicious JavaScript as part of the accordion.
Recent activity
- 2026-06-08 — latest release on wordpress.org (2.3.25).
- 2026-10-28 — PHP object injection disclosed (CVE-2026-116392), no fix listed yet.
- 2026-06-09 — Stored cross-site scripting (XSS) disclosed (CVE-2026-10862), fix version not stated.
- 2025-10-22 — Missing authorization check disclosed (CVE-2025-53421), fixed in 2.3.16.
Get an email when Accordions has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Accordions (accordions) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by PickPlugins (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (3) · PHP object injection (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/accordions (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/accordions"><img src="https://laskyr.com/plugins/accordions/badge.svg" alt="Accordions vulnerability status"></a>