Plugins · accessibility-toolbar · data as of 2026-11-04
Is Web Accessibility with Max Access safe? Known vulnerabilities and latest version
- Latest version
- 2.1.0
- Last updated
- 2025-08-28
- Active installs
- 700+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.8.12 · PHP 7.4+
The ultimate web accessibility plugin. Leverages AI to scan your site, fix website code, and improve SEO. Includes the web accessibility toolbar. — by Ability, Inc
What to do
- There is no fixed version yet. If you can live without Web Accessibility with Max Access for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get accessibility-toolbar --field=version shows what you run; wp plugin update accessibility-toolbar updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.9 affects latest 2.1.0 CVE-2026-24629 · published 2026-01-23
Stored cross-site scripting (XSS) in Web Accessibility with Max Access (2.1.0 and older)
- Affected
- 2.1.0 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ability, Inc Web Accessibility with Max Access accessibility-toolbar allows Stored XSS.This issue affects Web Accessibility with Max Access: from n/a through <= 2.1.0.
medium 4.3 CVE-2025-47681 · published 2025-05-07
Cross-site request forgery (CSRF) in Web Accessibility with Max Access (2.0.9 and older)
- Affected
- 2.0.9 and older
- Fixed in
- 2.1.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Ability, Inc Web Accessibility with Max Access accessibility-toolbar allows Cross Site Request Forgery.This issue affects Web Accessibility with Max Access: from n/a through <= 2.0.9.
Recent activity
- 2025-08-28 — latest release on wordpress.org (2.1.0).
- 2026-01-23 — Stored cross-site scripting (XSS) disclosed (CVE-2026-24629), no fix listed yet.
- 2025-05-07 — Cross-site request forgery (CSRF) disclosed (CVE-2025-47681), fixed in 2.1.0.
Get an email when Web Accessibility with Max Access has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Web Accessibility with Max Access (accessibility-toolbar) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/accessibility-toolbar (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/accessibility-toolbar"><img src="https://laskyr.com/plugins/accessibility-toolbar/badge.svg" alt="Web Accessibility with Max Access vulnerability status"></a>