Skip to content
Laskyr

Plugins · accessibility-checker · data as of 2026-11-04

Is Equalize Digital Accessibility Checker safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.52.0)

As of 2026-11-04. 6 issues are on record for older versions; version 1.47.0 or newer fixes all of them that state a fix.

Latest version
1.52.0
Last updated
2026-11-03
Active installs
10,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Find and fix accessibility issues with confidence. Real-time reports, automated fixes, and guidance. Reduce compliance risk and reach more users. — by Equalize Digital

What to do

  1. Update to the latest version (1.52.0). Anything older than 1.47.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get accessibility-checker --field=version shows what you run; wp plugin update accessibility-checker updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-14481 · published 2026-07-23

Stored cross-site scripting (XSS) in Equalize Digital Accessibility Checker (1.46.0 and older)

Affected
1.46.0 and older
Fixed in
1.47.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Equalize Digital Accessibility Checker – WCAG, ADA, EAA and Section 508 compliance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'html' parameter in all versions up to, and including, 1.46.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the attacker to have the ability to edit a post, as the REST endpoint /accessibility-checker/v1/post-scan-results/{id} is guarded only by the edit_post capability on the target post.

NVD CVE-2026-14481Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2026-9199 · published 2026-06-18

Missing authorization check in Equalize Digital Accessibility Checker (1.42.1 and older)

Affected
1.42.1 and older
Fixed in
1.43.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Equalize Digital Accessibility Checker – WCAG, ADA, EAA and Section 508 compliance plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.42.1. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with author-level access and above, to dismiss, ignore, or restore accessibility audit issue records belonging to posts they are not permitted to edit by supplying an issue from their own post as an authorization token to affect matching issues across the entire site. An Author-level user can exploit this by passing largeBatch=true on a dismiss-issue request referencing one of their own post's issues, causing the handler to bulk-modify all site-wide accessibility issues sharing the same 'object' value — including those belonging to administrator-owned posts.

NVD CVE-2026-9199Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2026-9015 · published 2026-05-28

Missing authorization check in Equalize Digital Accessibility Checker (1.42.0 and older)

Affected
1.42.0 and older
Fixed in
1.42.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Equalize Digital Accessibility Checker – WCAG, ADA, EAA and Section 508 compliance plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.42.0. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to modify the ignore state, ignore reason, and ignore comment of arbitrary accessibility issues across the entire site — including mass modification of all rows sharing an 'object' identifier when largeBatch=true is supplied — corrupting accessibility audit integrity by hiding or dismissing findings outside their authorization scope.

NVD CVE-2026-9015Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2025-58981 · published 2025-09-09

Missing authorization check in Equalize Digital Accessibility Checker (1.31.0 and older)

Affected
1.31.0 and older
Fixed in
1.31.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Equalize Digital Accessibility Checker by Equalize Digital accessibility-checker allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Accessibility Checker by Equalize Digital: from n/a through <= 1.31.0.

NVD CVE-2025-58981Patchstack advisory

medium 4.3 CVE-2025-58976 · published 2025-09-09

Missing authorization check in Equalize Digital Accessibility Checker (1.31.0 and older)

Affected
1.31.0 and older
Fixed in
1.31.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Equalize Digital Accessibility Checker by Equalize Digital accessibility-checker allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Accessibility Checker by Equalize Digital: from n/a through <= 1.31.0.

NVD CVE-2025-58976Patchstack advisory

medium 5.4 CVE-2025-57886 · published 2025-08-22

Missing authorization check in Equalize Digital Accessibility Checker (1.30.0 and older)

Affected
1.30.0 and older
Fixed in
1.30.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in Equalize Digital Accessibility Checker by Equalize Digital accessibility-checker allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Accessibility Checker by Equalize Digital: from n/a through <= 1.30.0.

NVD CVE-2025-57886Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Equalize Digital Accessibility Checker vulnerability status badge
<a href="https://laskyr.com/plugins/accessibility-checker"><img src="https://laskyr.com/plugins/accessibility-checker/badge.svg" alt="Equalize Digital Accessibility Checker vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit