Skip to content
Laskyr

Plugins · ablocks · data as of 2026-11-04

Is aBlocks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.18.0)

As of 2026-11-04. 6 issues are on record for older versions; version 2.18.0 or newer fixes all of them that state a fix.

Latest version
2.18.0
Last updated
2026-10-20
Active installs
2,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

aBlocks is a Gutenberg-based website builder with 100+ free flexible blocks and powerful form solutions, allowing you to build any type of form! — by Kodezen LLC

What to do

  1. Update to the latest version (2.18.0). Anything older than 2.18.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ablocks --field=version shows what you run; wp plugin update ablocks updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-110018 · published 2026-10-24

Privilege escalation in aBlocks (2.17.0 and older)

Affected
2.17.0 and older
Fixed in
2.18.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The aBlocks – Gutenberg Blocks, User Dashboard Builder, Popup Builder, Form Builder & Animation Builder plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 2.17.0 via the `/ablocks/v1/form-builder/registration` REST endpoint. The vulnerability exists because the endpoint is registered with `permission_callback => __return_true` and the `register()` handler reads `roleSlug` directly from attacker-controlled block attributes in `post_content` without ever verifying that the block's `formType` is `registration` — a condition that `RegistrationFormSanitizer::verify()` imposes only at save-time, meaning a Contributor can preserve an arbitrary `roleSlug` by saving a block with `formType='login'` and then triggering the endpoint via a valid `wp_rest` nonce and post-ownership check. This makes it possible for authenticated attackers, with Contributor-level access and above, to escalate their WordPress role to Editor or any other non-administrator role and receive a fully authenticated session at the elevated privilege level via `WP_User::set_role()` and `wp_set_auth_cookie()`. Escalation is bounded below administrator-tier roles because `is_safe_registration_role()` rejects any role holding `manage_options`, `edit_users`, `delete_users`, `create_users`, `promote_users`, or `edit_theme_options`, meaning the highest practically reachable role on a standard WordPress installation is Editor.

NVD CVE-2026-110018Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2026-40804 · published 2026-10-08

Reflected cross-site scripting (XSS) in aBlocks (2.16.0 and older)

Affected
2.16.0 and older
Fixed in
2.17.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kodezen LLC aBlocks ablocks allows Reflected XSS.This issue affects aBlocks: from n/a through 2.16.0.

NVD CVE-2026-40804Patchstack advisory

high 8.8 CVE-2026-57386 · published 2026-07-13

Privilege escalation in aBlocks (older than 2.9.1)

Affected
older than 2.9.1
Fixed in
2.9.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in Kodezen LLC aBlocks ablocks allows Privilege Escalation.This issue affects aBlocks: from n/a before 2.9.1.

NVD CVE-2026-57386Patchstack advisory

medium 5.4 CVE-2025-12449 · published 2026-01-07

Missing authorization check in aBlocks (2.4.0 and older)

Affected
2.4.0 and older
Fixed in
2.8.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The aBlocks – WordPress Gutenberg Blocks plugin for WordPress is vulnerable to unauthorized modification of data and disclosure of sensitive information due to missing capability checks on multiple AJAX actions in all versions up to, and including, 2.4.0. This makes it possible for authenticated attackers, with subscriber level access and above, to read plugin settings including block visibility, maintenance mode configuration, and third-party email marketing API keys, as well as read sensitive configuration data including API keys for email marketing services.

NVD CVE-2025-12449Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-47616 · published 2025-05-07

Stored cross-site scripting (XSS) in aBlocks (1.9.2 and older)

Affected
1.9.2 and older
Fixed in
1.9.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kodezen LLC aBlocks ablocks allows Stored XSS.This issue affects aBlocks: from n/a through <= 1.9.2.

NVD CVE-2025-47616Patchstack advisory

medium 5.4 CVE-2024-13465 · published 2025-02-18

Stored cross-site scripting (XSS) in aBlocks (1.6.1 and older)

Affected
1.6.1 and older
Fixed in
2.8.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The aBlocks – WordPress Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the "Table Of Content" Block, specifically in the "markerView" attribute, in all versions up to, and including, 1.6.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-13465Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
aBlocks vulnerability status badge
<a href="https://laskyr.com/plugins/ablocks"><img src="https://laskyr.com/plugins/ablocks/badge.svg" alt="aBlocks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit