Skip to content
Laskyr

Plugins · a4-barcode-generator · data as of 2026-11-04

Is Barcode Generator safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.3)

As of 2026-11-04. 5 issues are on record for older versions; version 4.0.1 or newer fixes all of them that state a fix.

Latest version
4.0.3
Last updated
2026-10-26
Active installs
900+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

WooCommerce barcode generator for product and order labels & price tags. Easily print label with your printer (UPC, EAN, GS1, GTIN, QRcode). — by Dmitry V. (CEO of "UKR Solution")

What to do

  1. Update to the latest version (4.0.3). Anything older than 4.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get a4-barcode-generator --field=version shows what you run; wp plugin update a4-barcode-generator updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-81280 · published 2026-08-31

Information disclosure in Barcode Generator (4.0.0 and older)

Affected
4.0.0 and older
Fixed in
4.0.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Sensitive Data Exposure in Print Barcode Labels for your WooCommerce products/orders <= 4.0.0 versions.

NVD CVE-2026-81280Patchstack advisory

medium 4.3 CVE-2025-24603 · published 2025-01-27

Missing authorization check in Barcode Generator (3.4.10 and older)

Affected
3.4.10 and older
Fixed in
3.4.11
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Dmitry V. (CEO of "UKR Solution") Print Barcode Labels for your WooCommerce products/orders a4-barcode-generator.This issue affects Print Barcode Labels for your WooCommerce products/orders: from n/a through <= 3.4.10.

NVD CVE-2025-24603Patchstack advisory

high 8.8 CVE-2024-43310 · published 2024-11-01

Missing authorization check in Barcode Generator (3.4.9 and older)

Affected
3.4.9 and older
Fixed in
3.4.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in UkrSolution Print Barcode Labels for your WooCommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Print Barcode Labels for your WooCommerce products/orders: from n/a through 3.4.9.

NVD CVE-2024-43310Patchstack advisory

high 8.8 CVE-2024-1677 · published 2024-05-02

Missing authorization check in Barcode Generator (3.4.6 and older)

Affected
3.4.6 and older
Fixed in
4.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Print Labels with Barcodes. Create price tags, product labels, order labels for WooCommerce plugin for WordPress is vulnerable to unauthorized access of data, modification of data, and loss of data due to an improper capability check on 42 separate AJAX functions in all versions up to, and including, 3.4.6. This makes it possible for authenticated attackers, with subscriber access and above, to fully control the plugin which includes the ability to modify plugin settings and profiles, and create, edit, retrieve, and delete templates and barcodes.

NVD CVE-2024-1677Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-1679 · published 2024-05-02

Stored cross-site scripting (XSS) in Barcode Generator (3.4.6 and older)

Affected
3.4.6 and older
Fixed in
4.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Print Labels with Barcodes. Create price tags, product labels, order labels for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the template and javascript label fields in all versions up to, and including, 3.4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-1679Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Barcode Generator vulnerability status badge
<a href="https://laskyr.com/plugins/a4-barcode-generator"><img src="https://laskyr.com/plugins/a4-barcode-generator/badge.svg" alt="Barcode Generator vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit