Skip to content
Laskyr

Plugins · a3-lazy-load · data as of 2026-11-04

Is a3 Lazy Load safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.9)

As of 2026-11-04. 2 issues are on record for older versions; version 2.7.7 or newer fixes all of them that state a fix.

Latest version
2.7.9
Last updated
2026-07-08
Active installs
80,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8

Use a3 Lazy Load for images, videos, iframes that are not lazy loaded by WordPress core. Instantly improve your sites load time and dramatically impro … — by Steve Truman

What to do

  1. Update to the latest version (2.7.9). Anything older than 2.7.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get a3-lazy-load --field=version shows what you run; wp plugin update a3-lazy-load updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-6427 · published 2026-05-28

Stored cross-site scripting (XSS) in a3 Lazy Load (2.7.6 and older)

Affected
2.7.6 and older
Fixed in
2.7.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The a3 Lazy Load plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.7.6 This is due to a regex bug in the _filter_videos() method that breaks HTML attribute quoting when processing crafted <video> elements, combined with unescaped output in the admin/views/form-data.php template. An authenticated attacker with Contributor-level access can insert a crafted <video> tag whose src attribute contains an embedded class=" substring that tricks the plugin's class-replacement regex into consuming an attribute-value closing quote. This shifts the HTML5 parser's quote boundary, promoting attacker-controlled text from inside a quoted attribute value into standalone event-handler attributes (autofocus, onfocus). The injected script executes in the browser of any user (including administrators) who views the post.

NVD CVE-2026-6427Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2025-9873 · published 2025-12-13

Stored cross-site scripting (XSS) in a3 Lazy Load (2.7.5 and older)

Affected
2.7.5 and older
Fixed in
2.7.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The a3 Lazy Load plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.7.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-9873Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
a3 Lazy Load vulnerability status badge
<a href="https://laskyr.com/plugins/a3-lazy-load"><img src="https://laskyr.com/plugins/a3-lazy-load/badge.svg" alt="a3 Lazy Load vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit