Plugins · 404-solution · data as of 2026-11-04
Is 404 Solution safe? Known vulnerabilities and latest version
- Latest version
- 4.3.6
- Last updated
- 2026-10-02
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Automatically redirect 404 errors to the right page using a 7-engine matching pipeline and spell-checking algorithm. Zero configuration required. — by Aaron
What to do
- Update to the latest version (4.3.6). Anything older than 3.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get 404-solution --field=version shows what you run; wp plugin update 404-solution updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2025-14477 · published 2025-12-13
SQL injection in 404 Solution (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.1 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The 404 Solution plugin for WordPress is vulnerable to SQL Injection in all versions up to, and including, 3.1.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This is due to improper sanitization of the `filterText` parameter in the `ajaxUpdatePaginationLinks` AJAX action. The sanitization logic can be bypassed by using the sequence `*$/` which becomes `*/` after the `$` character is removed, allowing attackers to escape SQL comment contexts. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database via a time-based blind SQL injection technique.
NVD CVE-2025-14477Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2024-11277 · published 2024-11-20
Reflected cross-site scripting (XSS) in 404 Solution (2.35.19 and older)
- Affected
- 2.35.19 and older
- Fixed in
- 2.36.10 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The 404 Solution plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via URLs in all versions up to, and including, 2.35.19 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
medium 5.3 CVE-2024-11094 · published 2024-11-16
Information disclosure in 404 Solution (2.35.17 and older)
- Affected
- 2.35.17 and older
- Fixed in
- 2.36.10 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The 404 Solution plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.35.17 via the export feature. This makes it possible for unauthenticated attackers to extract data such as redirects including GET parameters which may reveal sensitive information. On most sites this is unlikely to be the case.
high 7.2 CVE-2024-1068 · published 2024-03-11
SQL injection in 404 Solution (older than 2.35.8)
- Affected
- older than 2.35.8
- Fixed in
- 2.35.8
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The 404 Solution WordPress plugin before 2.35.8 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admins.
medium 5.3 CVE-2023-52146 · published 2024-01-05
Information disclosure in 404 Solution (2.33.0 and older)
- Affected
- 2.33.0 and older
- Fixed in
- 2.33.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Aaron J 404 Solution.This issue affects 404 Solution: from n/a through 2.33.0.
high 7.2 CVE-2023-50848 · published 2023-12-28
SQL injection in 404 Solution (2.34.0 and older)
- Affected
- 2.34.0 and older
- Fixed in
- 2.35.0
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Aaron J 404 Solution.This issue affects 404 Solution: from n/a through 2.34.0.
Recent activity
- 2026-10-02 — latest release on wordpress.org (4.3.6).
- 2025-12-13 — SQL injection disclosed (CVE-2025-14477), fixed in 3.1.1.
- 2024-11-20 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-11277), fixed in 2.36.10.
- 2024-11-16 — Information disclosure disclosed (CVE-2024-11094), fixed in 2.36.10.
Get an email when 404 Solution has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for 404 Solution (404-solution) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (3) · Sensitive data exposure (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/404-solution (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/404-solution"><img src="https://laskyr.com/plugins/404-solution/badge.svg" alt="404 Solution vulnerability status"></a>