Skip to content
Laskyr

Plugins · 3d-image-gallery · data as of 2026-11-04

Is Image Gallery Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.2)

As of 2026-11-04. 2 issues are on record for older versions; version 2.4.2 or newer fixes all of them that state a fix.

Latest version
2.4.2
Last updated
2026-11-04
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Responsive image gallery block for Gutenberg – photo galleries with grid & Polaroid layouts, albums, lightbox popups, and Pro Masonry & 3D layouts. — by bPlugins

What to do

  1. Update to the latest version (2.4.2). Anything older than 2.4.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get 3d-image-gallery --field=version shows what you run; wp plugin update 3d-image-gallery updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-115613 · published 2026-10-26

Stored cross-site scripting (XSS) in Image Gallery Block (2.4.1 and older)

Affected
2.4.1 and older
Fixed in
2.4.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Image Gallery block – Create and display photo gallery/photo album. 3d-image-gallery allows Stored XSS.This issue affects Image Gallery block – Create and display photo gallery/photo album.: from n/a through 2.4.1.

NVD CVE-2026-115613Patchstack advisory

high 7.1 CVE-2025-49394 · published 2025-11-06

Missing authorization check in Image Gallery Block (1.0.7 and older)

Affected
1.0.7 and older
Fixed in
2.0.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in bPlugins Image Gallery block – Create and display photo gallery/photo album. 3d-image-gallery allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Image Gallery block – Create and display photo gallery/photo album.: from n/a through <= 1.0.7.

NVD CVE-2025-49394Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Image Gallery Block vulnerability status badge
<a href="https://laskyr.com/plugins/3d-image-gallery"><img src="https://laskyr.com/plugins/3d-image-gallery/badge.svg" alt="Image Gallery Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit