Skip to content
Laskyr

PHP package security

Is tecnickcom/tcpdf vulnerable?

8 known security advisories for tecnickcom/tcpdf. The latest was reported on 2024-12-27 and is fixed in 6.8.0. The newest release, 7.0.21, is not affected by any of them.

1 critical 2 high 5 medium

Known advisories
8
Newest release
7.0.21
Released
2026-11-02
Affecting newest release
0
Last synced
2026-11-03

Deprecated legacy PDF engine for PHP. Use instead tecnickcom/tc-lib-pdf. · packagist.org/packages/tecnickcom/tcpdf

Check your version

Run composer show tecnickcom/tcpdf in your project to see the installed version, then enter it here.

Security advisories for tecnickcom/tcpdf

Newest first. “Affected” is the Composer version constraint from the advisory; “fixed in” is each version the advisory names as the first safe one on its release line.

ReportedAdvisorySeverityAffectedFixed in
2024-12-27 TCPDF missing character escape on error messages GHSA-qx95-cwh6-9mvq · CVE-2024-56527 · GitHub medium <6.8.0 6.8.0
2024-12-27 TCPDF has incorrect comparison GHSA-w95c-7994-ghpr · CVE-2024-56522 · GitHub high <6.8.0 6.8.0
2024-12-27 TCPDF lacks SVG sanitization GHSA-4p8j-vhjm-6pvw · CVE-2024-56519 · GitHub medium <6.8.0 6.8.0
2024-12-27 TCPDF missing certificate validation GHSA-9mgx-552f-59p6 · CVE-2024-56521 · GitHub high <6.8.0 6.8.0
2024-11-26 TCPDF Local File Inclusion vulnerability GHSA-rmv2-8jjc-23xw · CVE-2024-51058 · GitHub medium <=6.7.5 not stated
2024-04-19 TCPDF vulnerable to Regular Expression Denial of Service GHSA-mx3p-fhpw-x6rv · CVE-2024-22640 · GitHub medium <=6.7.4 not stated
2024-04-15 TCPDF Cross-site Scripting vulnerability GHSA-g9wg-98c2-qv3v · CVE-2024-32489 · GitHub medium <6.7.4 6.7.4
2018-09-14 Attackers can trigger deserialization of arbitrary data via the phar:// wrapper. CVE-2018-17057 · GitHub, FriendsOfPHP/security-advisories critical <6.2.22 6.2.22

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Check your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.

Check composer.lock

Questions about tecnickcom/tcpdf

Does tecnickcom/tcpdf have known vulnerabilities?

Yes. Packagist lists 8 security advisories for tecnickcom/tcpdf (1 critical, 2 high, 5 medium severity). The most recent, reported 2024-12-27, is "TCPDF missing character escape on error messages". The newest release, 7.0.21, is outside every affected range.

Which version of tecnickcom/tcpdf should I run?

The newest stable release is 7.0.21 (published 2026-11-02). The most recent advisory is fixed in 6.8.0, so stay on or above the fixed version for your major version. Run composer update tecnickcom/tcpdf, then composer audit to confirm nothing else is flagged.

How do I check if my tecnickcom/tcpdf version is affected?

Run composer show tecnickcom/tcpdf in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.

Where this data comes from

Advisories come from the Packagist security advisories API, which collects the GitHub Advisory Database and the FriendsOfPHP security advisories. composer audit reads the same data. Releases come from packagist.org. Last synced 2026-11-03; we re-check daily. Each advisory links to its source. Spot an error? Tell us.

← All PHP packages

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit