PHP package security
Is symfony/security-core vulnerable?
5 known security advisories for symfony/security-core. The latest was reported on 2021-05-12 and is fixed in 3.0.0, 3.1.0, 3.2.0, 3.3.0, 3.4.0, 3.4.49, 4.1.0, 4.2.0, 4.3.0, 4.4.0, 4.4.24, 5.1.0, 5.2.0 and 5.2.9. The newest release, 8.1.10, is not affected by any of them.
3 critical 1 high 1 medium
- Known advisories
- 5
- Newest release
- 8.1.10
- Released
- 2026-10-25
- Affecting newest release
- 0
- Last synced
- 2026-11-03
Check your version
Security advisories for symfony/security-core
| Reported | Advisory | Severity | Affected | Fixed in |
|---|---|---|---|---|
| 2021-05-12 | CVE-2021-21424: Prevent user enumeration via response content in authentication mechanisms CVE-2021-21424 · GitHub, FriendsOfPHP/security-advisories | medium | >=2.8.0,<3.0.0 | >=3.0.0,<3.1.0 | >=3.1.0,<3.2.0 | >=3.2.0,<3.3.0 | >=3.3.0,<3.4.0 | >=3.4.0,<3.4.49 | >=4.0.0,<4.1.0 | >=4.1.0,<4.2.0 | >=4.2.0,<4.3.0 | >=4.3.0,<4.4.0 | >=4.4.0,<4.4.24 | >=5.0.0,<5.1.0 | >=5.1.0,<5.2.0 | >=5.2.0,<5.2.9 | 3.0.0, 3.1.0, 3.2.0, 3.3.0, 3.4.0, 3.4.49, 4.1.0, 4.2.0, 4.3.0, 4.4.0, 4.4.24, 5.1.0, 5.2.0, 5.2.9 |
| 2018-05-25 | CVE-2018-11407: Unauthorized access on a misconfigured LDAP server when using an empty password CVE-2018-11407 · GitHub, FriendsOfPHP/security-advisories | critical | >=2.8.0,<2.8.37 | >=3.0.0,<3.1.0 | >=3.1.0,<3.2.0 | >=3.2.0,<3.3.0 | >=3.3.0,<3.3.17 | >=3.4.0,<3.4.7 | >=4.0.0,<4.0.7 | 2.8.37, 3.1.0, 3.2.0, 3.3.0, 3.3.17, 3.4.7, 4.0.7 |
| 2017-07-17 | CVE-2017-11365: Empty passwords validation issue CVE-2017-11365 · GitHub, FriendsOfPHP/security-advisories | critical | >=2.7.30,<2.7.32 | >=2.8.23,<2.8.25 | >=3.2.10,<3.2.12 | >=3.3.3,<3.3.5 | 2.7.32, 2.8.25, 3.2.12, 3.3.5 |
| 2016-05-09 | CVE-2016-2403: Unauthorized access on a misconfigured Ldap server when using an empty password CVE-2016-2403 · GitHub, FriendsOfPHP/security-advisories | critical | >=2.8.0,<2.8.6 | >=3.0.0,<3.0.6 | 2.8.6, 3.0.6 |
| 2016-01-14 | CVE-2016-1902: SecureRandom's fallback not secure when OpenSSL fails CVE-2016-1902 · GitHub, FriendsOfPHP/security-advisories | high | >=2.4.0,<2.5.0 | >=2.5.0,<2.6.0 | >=2.6.0,<2.6.13 | >=2.7.0,<2.7.9 | 2.5.0, 2.6.0, 2.6.13, 2.7.9 |
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixCheck your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.
Check composer.lockQuestions about symfony/security-core
Does symfony/security-core have known vulnerabilities?
Yes. Packagist lists 5 security advisories for symfony/security-core (3 critical, 1 high, 1 medium severity). The most recent, reported 2021-05-12, is "CVE-2021-21424: Prevent user enumeration via response content in authentication mechanisms". The newest release, 8.1.10, is outside every affected range.
Which version of symfony/security-core should I run?
The newest stable release is 8.1.10 (published 2026-10-25). The most recent advisory is fixed in 3.0.0, 3.1.0, 3.2.0, 3.3.0, 3.4.0, 3.4.49, 4.1.0, 4.2.0, 4.3.0, 4.4.0, 4.4.24, 5.1.0, 5.2.0 and 5.2.9, so stay on or above the fixed version for your major version. Run composer update symfony/security-core, then composer audit to confirm nothing else is flagged.
How do I check if my symfony/security-core version is affected?
Run composer show symfony/security-core in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.