Skip to content
Laskyr

PHP package security

Is symfony/routing vulnerable?

4 known security advisories for symfony/routing. The latest was reported on 2026-05-26 and is fixed in 3.0.0, 4.0.0, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 5.4.0, 5.4.53, 6.1.0, 6.2.0, 6.3.0, 6.4.0, 6.4.41, 7.1.0, 7.2.0, 7.3.0, 7.4.0, 7.4.13 and 8.0.13. The newest release, 8.1.10, is not affected by any of them.

1 high 3 medium

Known advisories
4
Newest release
8.1.10
Released
2026-10-26
Affecting newest release
0
Last synced
2026-11-03

Maps an HTTP request to a set of configuration variables · packagist.org/packages/symfony/routing

Check your version

Run composer show symfony/routing in your project to see the installed version, then enter it here.

Security advisories for symfony/routing

Newest first. “Affected” is the Composer version constraint from the advisory; “fixed in” is each version the advisory names as the first safe one on its release line.

ReportedAdvisorySeverityAffectedFixed in
2026-05-26 CVE-2026-48784: UrlGenerator Dot-Segment Encoding Skips Every Other Chained `../` or `./` → Generated URL Collapses Off-Route Under RFC 3986 Normalization CVE-2026-48784 · GitHub, FriendsOfPHP/security-advisories medium >=2.0.0,<3.0.0 | >=3.0.0,<4.0.0 | >=4.0.0,<5.0.0 | >=5.0.0,<5.1.0 | >=5.1.0,<5.2.0 | >=5.2.0,<5.3.0 | >=5.3.0,<5.4.0 | >=5.4.0,<5.4.53 | >=6.0.0,<6.1.0 | >=6.1.0,<6.2.0 | >=6.2.0,<6.3.0 | >=6.3.0,<6.4.0 | >=6.4.0,<6.4.41 | >=7.0.0,<7.1.0 | >=7.1.0,<7.2.0 | >=7.2.0,<7.3.0 | >=7.3.0,<7.4.0 | >=7.4.0,<7.4.13 | >=8.0.0,<8.0.13 3.0.0, 4.0.0, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 5.4.0, 5.4.53, 6.1.0, 6.2.0, 6.3.0, 6.4.0, 6.4.41, 7.1.0, 7.2.0, 7.3.0, 7.4.0, 7.4.13, 8.0.13
2026-05-20 CVE-2026-45065: UrlGenerator Route-Requirement Bypass via Unanchored Regex Alternation → Off-Site //host URL Injection CVE-2026-45065 · GitHub, FriendsOfPHP/security-advisories medium >=2.0.0,<3.0.0 | >=3.0.0,<4.0.0 | >=4.0.0,<5.0.0 | >=5.0.0,<5.1.0 | >=5.1.0,<5.2.0 | >=5.2.0,<5.3.0 | >=5.3.0,<5.4.0 | >=5.4.0,<5.4.52 | >=6.0.0,<6.1.0 | >=6.1.0,<6.2.0 | >=6.2.0,<6.3.0 | >=6.3.0,<6.4.0 | >=6.4.0,<6.4.40 | >=7.0.0,<7.1.0 | >=7.1.0,<7.2.0 | >=7.2.0,<7.3.0 | >=7.3.0,<7.4.0 | >=7.4.0,<7.4.12 | >=8.0.0,<8.0.12 3.0.0, 4.0.0, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 5.4.0, 5.4.52, 6.1.0, 6.2.0, 6.3.0, 6.4.0, 6.4.40, 7.1.0, 7.2.0, 7.3.0, 7.4.0, 7.4.12, 8.0.12
2012-08-28 Security fixes related to the way XML is handled Advisory · GitHub, FriendsOfPHP/security-advisories high >=2.0.0,<2.0.17 2.0.17
2012-03-19 Routes behind a firewall are accessible even when not logged in CVE-2012-6431 · GitHub, FriendsOfPHP/security-advisories medium >=2.0.0,<2.0.19 2.0.19

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Check your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.

Check composer.lock

Questions about symfony/routing

Does symfony/routing have known vulnerabilities?

Yes. Packagist lists 4 security advisories for symfony/routing (1 high, 3 medium severity). The most recent, reported 2026-05-26, is "CVE-2026-48784: UrlGenerator Dot-Segment Encoding Skips Every Other Chained `../` or `./` → Generated URL Collapses Off-Route Under RFC 3986 Normalization". The newest release, 8.1.10, is outside every affected range.

Which version of symfony/routing should I run?

The newest stable release is 8.1.10 (published 2026-10-26). The most recent advisory is fixed in 3.0.0, 4.0.0, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 5.4.0, 5.4.53, 6.1.0, 6.2.0, 6.3.0, 6.4.0, 6.4.41, 7.1.0, 7.2.0, 7.3.0, 7.4.0, 7.4.13 and 8.0.13, so stay on or above the fixed version for your major version. Run composer update symfony/routing, then composer audit to confirm nothing else is flagged.

How do I check if my symfony/routing version is affected?

Run composer show symfony/routing in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.

Where this data comes from

Advisories come from the Packagist security advisories API, which collects the GitHub Advisory Database and the FriendsOfPHP security advisories. composer audit reads the same data. Releases come from packagist.org. Last synced 2026-11-03; we re-check daily. Each advisory links to its source. Spot an error? Tell us.

← All PHP packages

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit