Skip to content
Laskyr

PHP package security

Is league/oauth2-server vulnerable?

1 known security advisory for league/oauth2-server. The latest was reported on 2023-07-06 and is fixed in 8.4.2 and 8.5.3. The newest release, 9.4.1, is not affected by any of them.

1 high

Known advisories
1
Newest release
9.4.1
Released
2026-06-25
Affecting newest release
0
Last synced
2026-11-03

A lightweight and powerful OAuth 2.0 authorization and resource server library with support for all the core specification grants. This library will allow you to secure your API with OAuth and allow your applications users to approve apps that want to access their data from your API. · packagist.org/packages/league/oauth2-server

Check your version

Run composer show league/oauth2-server in your project to see the installed version, then enter it here.

Security advisories for league/oauth2-server

Newest first. “Affected” is the Composer version constraint from the advisory; “fixed in” is each version the advisory names as the first safe one on its release line.

ReportedAdvisorySeverityAffectedFixed in
2023-07-06 league/oauth2-server key exposed in exception message when passing as a string and providing an invalid pass phrase GHSA-wj7q-gjg8-3cpm · CVE-2023-37260 · GitHub high >=8.5.0,<8.5.3 | >=8.3.2,<8.4.2 8.4.2, 8.5.3

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Check your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.

Check composer.lock

Questions about league/oauth2-server

Does league/oauth2-server have known vulnerabilities?

Yes. Packagist lists 1 security advisory for league/oauth2-server (1 high severity). The most recent, reported 2023-07-06, is "league/oauth2-server key exposed in exception message when passing as a string and providing an invalid pass phrase". The newest release, 9.4.1, is outside every affected range.

Which version of league/oauth2-server should I run?

The newest stable release is 9.4.1 (published 2026-06-25). The most recent advisory is fixed in 8.4.2 and 8.5.3, so stay on or above the fixed version for your major version. Run composer update league/oauth2-server, then composer audit to confirm nothing else is flagged.

How do I check if my league/oauth2-server version is affected?

Run composer show league/oauth2-server in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.

Where this data comes from

Advisories come from the Packagist security advisories API, which collects the GitHub Advisory Database and the FriendsOfPHP security advisories. composer audit reads the same data. Releases come from packagist.org. Last synced 2026-11-03; we re-check daily. Each advisory links to its source. Spot an error? Tell us.

← All PHP packages

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit