PHP package security
Is lcobucci/jwt vulnerable?
1 known security advisory for lcobucci/jwt. The latest was reported on 2021-09-28 and is fixed in 3.4.6, 4.0.4 and 4.1.5. The newest release, 5.6.1, is not affected by any of them.
1 medium
- Known advisories
- 1
- Newest release
- 5.6.1
- Released
- 2026-10-10
- Affecting newest release
- 0
- Last synced
- 2026-11-03
Check your version
Security advisories for lcobucci/jwt
| Reported | Advisory | Severity | Affected | Fixed in |
|---|---|---|---|---|
| 2021-09-28 | CVE-2021-41106: File reference keys leads to incorrect hashes on HMAC algorithms CVE-2021-41106 · GitHub, FriendsOfPHP/security-advisories | medium | >=3.4.0,<3.4.6 | >=4.0.0,<4.0.4 | >=4.1.0,<4.1.5 | 3.4.6, 4.0.4, 4.1.5 |
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixCheck your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.
Check composer.lockQuestions about lcobucci/jwt
Does lcobucci/jwt have known vulnerabilities?
Yes. Packagist lists 1 security advisory for lcobucci/jwt (1 medium severity). The most recent, reported 2021-09-28, is "CVE-2021-41106: File reference keys leads to incorrect hashes on HMAC algorithms". The newest release, 5.6.1, is outside every affected range.
Which version of lcobucci/jwt should I run?
The newest stable release is 5.6.1 (published 2026-10-10). The most recent advisory is fixed in 3.4.6, 4.0.4 and 4.1.5, so stay on or above the fixed version for your major version. Run composer update lcobucci/jwt, then composer audit to confirm nothing else is flagged.
How do I check if my lcobucci/jwt version is affected?
Run composer show lcobucci/jwt in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.