PHP package security
Is laravel/passport vulnerable?
1 known security advisory for laravel/passport. The latest was reported on 2026-04-08 and is fixed in 13.7.1. The newest release, 13.10.0, is not affected by any of them.
1 high
- Known advisories
- 1
- Newest release
- 13.10.0
- Released
- 2026-10-08
- Affecting newest release
- 0
- Last synced
- 2026-11-03
Check your version
Security advisories for laravel/passport
| Reported | Advisory | Severity | Affected | Fixed in |
|---|---|---|---|---|
| 2026-04-08 | Laravel Passport: TokenGuard Authenticates Unrelated User for Client Credentials Tokens GHSA-349c-2h2f-mxf6 · CVE-2026-39976 · GitHub | high | >=13.0.0,<13.7.1 | 13.7.1 |
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixCheck your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.
Check composer.lockQuestions about laravel/passport
Does laravel/passport have known vulnerabilities?
Yes. Packagist lists 1 security advisory for laravel/passport (1 high severity). The most recent, reported 2026-04-08, is "Laravel Passport: TokenGuard Authenticates Unrelated User for Client Credentials Tokens". The newest release, 13.10.0, is outside every affected range.
Which version of laravel/passport should I run?
The newest stable release is 13.10.0 (published 2026-10-08). The most recent advisory is fixed in 13.7.1, so stay on or above the fixed version for your major version. Run composer update laravel/passport, then composer audit to confirm nothing else is flagged.
How do I check if my laravel/passport version is affected?
Run composer show laravel/passport in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.