Skip to content
Laskyr

PHP package security

Is guzzlehttp/psr7 vulnerable?

6 known security advisories for guzzlehttp/psr7. The latest was reported on 2026-07-21 and is fixed in 2.12.3. The newest release, 3.2.0, is not affected by any of them.

6 medium

Known advisories
6
Newest release
3.2.0
Released
2026-10-17
Affecting newest release
0
Last synced
2026-11-03

PSR-7 message implementation that also provides common utility methods · packagist.org/packages/guzzlehttp/psr7

Check your version

Run composer show guzzlehttp/psr7 in your project to see the installed version, then enter it here.

Security advisories for guzzlehttp/psr7

Newest first. “Affected” is the Composer version constraint from the advisory; “fixed in” is each version the advisory names as the first safe one on its release line.

ReportedAdvisorySeverityAffectedFixed in
2026-07-21 guzzlehttp/psr7: Host Confusion via Weak URI Host Validation GHSA-c2w2-prh8-qm98 · CVE-2026-59882 · GitHub medium <2.12.3 2.12.3
2026-06-18 CRLF injection in HTTP start-line serialization CVE-2026-55766 · GitHub, FriendsOfPHP/security-advisories medium <2.12.1 2.12.1
2026-05-25 Host confusion via authority reinterpretation CVE-2026-48998 · GitHub, FriendsOfPHP/security-advisories medium <2.10.2 2.10.2
2026-05-25 CRLF injection via URI host component CVE-2026-49214 · GitHub, FriendsOfPHP/security-advisories medium <2.10.2 2.10.2
2023-04-17 Improper header validation CVE-2023-29197 · GitHub, FriendsOfPHP/security-advisories medium >=2,<2.4.5 | <1.9.1 1.9.1, 2.4.5
2022-03-20 Inproper parsing of HTTP headers CVE-2022-24775 · GitHub, FriendsOfPHP/security-advisories medium >=2,<2.1.1 | <1.8.4 1.8.4, 2.1.1

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Check your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.

Check composer.lock

Questions about guzzlehttp/psr7

Does guzzlehttp/psr7 have known vulnerabilities?

Yes. Packagist lists 6 security advisories for guzzlehttp/psr7 (6 medium severity). The most recent, reported 2026-07-21, is "guzzlehttp/psr7: Host Confusion via Weak URI Host Validation". The newest release, 3.2.0, is outside every affected range.

Which version of guzzlehttp/psr7 should I run?

The newest stable release is 3.2.0 (published 2026-10-17). The most recent advisory is fixed in 2.12.3, so stay on or above the fixed version for your major version. Run composer update guzzlehttp/psr7, then composer audit to confirm nothing else is flagged.

How do I check if my guzzlehttp/psr7 version is affected?

Run composer show guzzlehttp/psr7 in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.

Where this data comes from

Advisories come from the Packagist security advisories API, which collects the GitHub Advisory Database and the FriendsOfPHP security advisories. composer audit reads the same data. Releases come from packagist.org. Last synced 2026-11-03; we re-check daily. Each advisory links to its source. Spot an error? Tell us.

← All PHP packages

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit