PHP package security
Is doctrine/orm vulnerable?
3 known security advisories for doctrine/orm. The latest was reported on 2021-04-06 and is fixed in 2.8.4. The newest release, 3.7.6, is not affected by any of them.
1 critical 2 high
- Known advisories
- 3
- Newest release
- 3.7.6
- Released
- 2026-10-30
- Affecting newest release
- 0
- Last synced
- 2026-11-03
Check your version
Security advisories for doctrine/orm
| Reported | Advisory | Severity | Affected | Fixed in |
|---|---|---|---|---|
| 2021-04-06 | Regression in Query Parenthesis can have Security Implications Advisory · FriendsOfPHP/security-advisories, GitHub | critical | >=2.8.3,<2.8.4 | 2.8.4 |
| 2015-08-31 | Security Misconfiguration Vulnerability in various Doctrine projects CVE-2015-5723 · FriendsOfPHP/security-advisories, GitHub | high | >=2.0.0,<2.4.8 | >=2.5.0,<2.5.1 | 2.4.8, 2.5.1 |
| 2011-09-25 | SQL injection possibility Advisory · FriendsOfPHP/security-advisories, GitHub | high | >=2.0.0,<2.0.3 | 2.0.3 |
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixCheck your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.
Check composer.lockQuestions about doctrine/orm
Does doctrine/orm have known vulnerabilities?
Yes. Packagist lists 3 security advisories for doctrine/orm (1 critical, 2 high severity). The most recent, reported 2021-04-06, is "Regression in Query Parenthesis can have Security Implications". The newest release, 3.7.6, is outside every affected range.
Which version of doctrine/orm should I run?
The newest stable release is 3.7.6 (published 2026-10-30). The most recent advisory is fixed in 2.8.4, so stay on or above the fixed version for your major version. Run composer update doctrine/orm, then composer audit to confirm nothing else is flagged.
How do I check if my doctrine/orm version is affected?
Run composer show doctrine/orm in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.