Skip to content
Laskyr

CVE-2026-97315: Responsive Blocks content injection vulnerability

medium 5.4 published 2026-10-14

Fixed in Responsive Blocks 2.3.0

Responsive Blocks older than 2.3.0 is affected by this content injection issue. Sites on 2.3.0 or newer are not affected; the latest release is 2.3.0.

Affected versions
older than 2.3.0
Fixed in
2.3.0
Latest version
2.3.0
Severity
Medium · CVSS 5.4
Active installs
3,000+
Type
Content injection

What an attacker needs

CVSS vector (score by WPScan): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

What to do now

  1. Update Responsive Blocks to 2.3.0 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Responsive Blocks issue. With WP-CLI: wp plugin get responsive-block-editor-addons --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Responsive Blocks WordPress plugin before 2.3.0 does not sanitise or escape some of the values submitted with its Form block before adding them to the HTML notification email sent to the site owner, allowing unauthenticated users to inject arbitrary HTML, such as phishing links, into that email.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-97315.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit