Skip to content
Laskyr

CVE-2026-97070: Cozy Blocks missing authorization check vulnerability

medium 6.9 published 2026-10-05 · updated 2026-10-06

Fixed in Cozy Blocks 2.2.24

Cozy Blocks 2.2.23 and older is affected by this missing authorization issue. Sites on 2.2.24 or newer are not affected; the latest release is 2.2.29.

Affected versions
2.2.23 and older
Fixed in
2.2.24
Latest version
2.2.29
Severity
Medium · CVSS 6.9
Active installs
6,000+
Type
Missing authorization check

What an attacker needs

CVSS vector (score by Patchstack): CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/M

What to do now

  1. Update Cozy Blocks to 2.2.24 or newer (the latest is 2.2.29): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Cozy Blocks issue. With WP-CLI: wp plugin get cozy-addons --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Authorization Bypass Through User-Controlled Key vulnerability in CozyThemes Cozy Blocks cozy-addons allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Cozy Blocks: from n/a through 2.2.23.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-97070.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit