Skip to content
Laskyr

CVE-2026-95594: SMS Alert privilege escalation vulnerability

high 8.1 published 2026-10-06 · updated 2026-10-12

Fixed in SMS Alert 4.0.1

SMS Alert 4.0.0 and older is affected by this privilege escalation issue. Sites on 4.0.1 or newer are not affected; the latest release is 4.0.3.

Affected versions
4.0.0 and older
Fixed in
4.0.1
Latest version
4.0.3
Severity
High · CVSS 8.1
Active installs
3,000+
Type
Privilege escalation

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update SMS Alert to 4.0.1 or newer (the latest is 4.0.3): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known SMS Alert issue. With WP-CLI: wp plugin get sms-alert --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Incorrect Privilege Assignment vulnerability in Cozy Vision Technologies Pvt. Ltd. SMS Alert Order Notifications sms-alert allows Privilege Escalation.This issue affects SMS Alert Order Notifications: from n/a through 4.0.0.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-95594.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit