Skip to content
Laskyr

CVE-2026-94668: Salon Booking System reflected cross-site scripting (XSS) vulnerability

high 7.1 published 2026-10-09

Fixed in Salon Booking System 10.31.6

Salon Booking System 10.31.5 and older is affected by this reflected XSS issue. Sites on 10.31.6 or newer are not affected; the latest release is 10.31.14.

Affected versions
10.31.5 and older
Fixed in
10.31.6
Latest version
10.31.14
Severity
High · CVSS 7.1
Active installs
2,000+
Type
Reflected cross-site scripting (XSS)

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

What to do now

  1. Update Salon Booking System to 10.31.6 or newer (the latest is 10.31.14): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Salon Booking System issue. With WP-CLI: wp plugin get salon-booking-system --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Dimitri Grassi Salon booking system salon-booking-system allows Reflected XSS.This issue affects Salon booking system: from n/a through 10.31.5.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-94668.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit