Skip to content
Laskyr

CVE-2026-93775: Podlove Podcast Publisher stored cross-site scripting (XSS) vulnerability

high 7.2 published 2026-10-10 · updated 2026-10-13

Fixed in Podlove Podcast Publisher 4.5.7 (first release after the affected range)

Podlove Podcast Publisher 4.5.6 and older is affected by this stored XSS issue. Sites on 4.5.7 or newer are not affected; the latest release is 4.5.8.

Affected versions
4.5.6 and older
Fixed in
4.5.7 *
Latest version
4.5.8
Severity
High · CVSS 7.2
Active installs
3,000+
Type
Stored cross-site scripting (XSS)

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

What to do now

  1. Update Podlove Podcast Publisher to 4.5.7 or newer (the latest is 4.5.8): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Podlove Podcast Publisher issue. With WP-CLI: wp plugin get podlove-podcasting-plugin-for-wordpress --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Podlove Podcast Publisher plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Auphonic Webhook in all versions up to, and including, 4.5.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injection is triggered by submitting a request to the Auphonic webhook endpoint with any POST body where the status_string field is not the literal string 'Done', causing the full raw POST superglobal to be stored in the plugin log before any authentication key validation is performed.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-93775.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit