Skip to content
Laskyr

CVE-2026-87971: If-So Dynamic Content cross-site scripting (XSS) vulnerability

high 7.1 published 2026-10-07

Fixed in If-So Dynamic Content 1.10.2

If-So Dynamic Content 1.4.4 up to (not including) 1.10.2 is affected by this XSS issue. Sites on 1.10.2 or newer are not affected; the latest release is 1.10.3.

Affected versions
1.4.4 up to (not including) 1.10.2
Fixed in
1.10.2
Latest version
1.10.3
Severity
High · CVSS 7.1
Active installs
7,000+
Type
Cross-site scripting (XSS)

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

What to do now

  1. Update If-So Dynamic Content to 1.10.2 or newer (the latest is 1.10.3): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known If-So Dynamic Content issue. With WP-CLI: wp plugin get if-so --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The If-So Dynamic Content WordPress plugin before 1.10.2 does not validate the URL scheme of a request-supplied value before reflecting it into a link on an admin page, allowing attackers to execute arbitrary JavaScript in the browser of a logged-in user who opens a crafted link.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-87971.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit