Skip to content
Laskyr

CVE-2026-85655: Enable Media Replace missing authorization check vulnerability

medium 4.3 published 2026-10-28 · updated 2026-10-29

Fixed in Enable Media Replace 4.2.3 (first release after the affected range)

Enable Media Replace 4.2.2 and older is affected by this missing authorization issue. Sites on 4.2.3 or newer are not affected; the latest release is 4.2.3.

Affected versions
4.2.2 and older
Fixed in
4.2.3 *
Latest version
4.2.3
Severity
Medium · CVSS 4.3
Active installs
600,000+
Type
Missing authorization check

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

What to do now

  1. Update Enable Media Replace to 4.2.3 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Enable Media Replace issue. With WP-CLI: wp plugin get enable-media-replace --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Enable Media Replace plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.2.2. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with author-level access and above, to modify the post_content of any published post referencing the replaced media — including Administrator-owned posts — making changes immediately visible to unauthenticated visitors. The doReplaceQuery() method performs a database-wide search-and-replace across all posts containing the old media URL without any per-post capability check, meaning a single Author-triggered request can silently overwrite a large number of posts that WordPress's standard admin UI and REST API would otherwise forbid that user from editing.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-85655.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit