Skip to content
Laskyr

CVE-2026-85642: Formidable Forms denial of service vulnerability

high 7.5 published 2026-10-21

Fixed in Formidable Forms 7.0

Formidable Forms 6.5 up to (not including) 7.0 is affected by this denial of service issue. Sites on 7.0 or newer are not affected; the latest release is 7.0.

Affected versions
6.5 up to (not including) 7.0
Fixed in
7.0
Latest version
7.0
Severity
High · CVSS 7.5
Active installs
300,000+
Type
Denial of service

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

What to do now

  1. Update Formidable Forms to 7.0 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Formidable Forms issue. With WP-CLI: wp plugin get formidable --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Formidable Forms WordPress plugin before 7.0 does not verify the identity of the caller before recording the timestamp it uses to rate limit payment gateway verification requests, allowing unauthenticated attackers to consume the daily allowance and cause legitimate verification attempts to be refused for the next 24 hours.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-85642.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit