Skip to content
Laskyr

predis/predis security advisory

CVE-2026-84372: Predis: Redis command injection and denial of service via CRLF smuggling in pipelined commands on aggregate connections

CVE-2026-84372 is a critical-severity denial of service vulnerability in the PHP package predis/predis (CVSS 9.8), published 1 September 2026. It is fixed in 3.3.0; earlier versions are affected. It can be exploited without an account.

critical 9.8 published 2026-09-01 · updated 2026-09-09

Fixed in predis/predis 3.3.0

This denial of service issue affects predis/predis versions >= 3.0.0-RC1, < 3.3.0. Upgrade to the fixed version for your release line (3.3.0). The newest release, 3.7.1, is not affected.

Affected versions
>= 3.0.0-RC1, < 3.3.0
Fixed in
3.3.0
Newest release
3.7.1
Severity
Critical · CVSS 9.8
Type
Denial of service
CWE-93
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your predis/predis version affected?

Run composer show predis/predis in your project, then enter the version. We check it against this and every other known predis/predis advisory.

Who can exploit CVE-2026-84372

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Your app is only exposed if it uses the affected part of predis/predis. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-84372 in predis/predis

  1. Find the installed version: composer show predis/predis. If you never required it yourself, composer why predis/predis shows which package pulls it in.
  2. Update it: composer update predis/predis --with-all-dependencies. You need 3.3.0 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "predis/predis": "^3.3.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-84372.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for denial of service issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-84372 advisory

Predis is a flexible and feature-complete Redis and Valkey client for PHP. From version 3.0.0-RC1 until version 3.3.0, pipeline handling on aggregate cluster and replication connections reparses an already serialized RESP buffer in AbstractAggregateConnection::write() by splitting it with explode("\r\n") instead of honoring RESP length prefixes. Attacker-controlled keys or values containing CRLF sequences can therefore be interpreted by Command::deserializeCommand() as additional commands. On cluster connections, ClusterStrategy::getFakeKey() can route injected keyless commands using the literal fake key value "key", permitting operations such as shard-wide cache deletion, targeted data modification, data reads, or node disruption. On replication connections, malformed reparsing can throw an uncaught exception and repeatedly terminate affected requests. Only pipeline() reaches this vulnerable path; transaction() and MULTI are not affected. This issue is fixed in version 3.3.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-84372. Advisory title: “Predis: Redis command injection and denial of service via CRLF smuggling in pipelined commands on aggregate connections”.

References

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit