livewire/livewire security advisory
CVE-2026-81887: Livewire DOM-based cross-site scripting during client-side state handling
CVE-2026-81887 is a medium-severity DOM-based XSS vulnerability in the PHP package livewire/livewire (CVSS 5.1), published 31 August 2026. The advisory does not name a fixed version. It can be exploited without an account.
medium 5.1 published 2026-08-31 · updated 2026-09-09
- Affected versions
- >= 3.0.0-beta.1, <= 3.8.2
>= 4.0.0-beta.1, <= 4.3.3 - Fixed in
- not stated
- Newest release
- 4.4.8
- Severity
- Medium · CVSS 5.1
- Type
- DOM-based cross-site scripting (XSS)
CWE-79, CWE-1321 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your livewire/livewire version affected?
Who can exploit CVE-2026-81887
- Access: No account. Anyone who can send a request to an app that uses the affected code.
- Interaction: A user also has to do something, such as open a link or a page the attacker prepared.
CVSS vector (scored by GitHub): CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
How to fix CVE-2026-81887 in livewire/livewire
- Find the installed version:
composer show livewire/livewire. If you never required it yourself,composer why livewire/livewireshows which package pulls it in. - Update it:
composer update livewire/livewire --with-all-dependencies. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"livewire/livewire": "^4.4.8"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-81887. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Escape output in your own templates and add a Content-Security-Policy that blocks inline scripts.
- Limit who can save the content the advisory names (for example rich text, SVG or form fields).
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-81887 advisory
Livewire is a full-stack framework for Laravel. From 3.0.0-beta.1 until 3.8.3 and 4.3.4, the dot-notated query-string parser in js/plugins/history/index.js, including fromQueryString() and insertDotNotatedValueIntoData(), accepts the __proto__, constructor, and prototype path segments and creates inherited objects. Client-side state handlers then access effects.html, effects.js, effects.xjs, and effects.scripts without Object.prototype.hasOwnProperty.call(), allowing inherited attacker-controlled state to be treated as trusted effects. An unauthenticated attacker can craft a URL that, when opened by a user, executes arbitrary JavaScript in the affected application's origin. Exploitation requires user interaction and does not bypass server-side authorization or grant privileges beyond the affected user. This issue is fixed in versions 3.8.3 and 4.3.4.
References
- GitHub advisory GHSA-g3hc-697w-wm82 github.com
- Fix commit 11ebe64 github.com
- Pull request #10467 github.com
- Release v3.8.3 github.com
- Release v4.3.4 github.com
Other livewire/livewire advisories
- medium Livewire: Authorization bypass in #[Authorize] via reordered parameter keys and #[Json] execution order 2026-10-23
- critical CVE-2025-54068: Livewire is vulnerable to remote command execution during component property update hydration 2025-07-17
- high CVE-2024-47823: Livewire Remote Code Execution on File Uploads 2024-10-08
- medium CVE-2024-21504: Cross-site Scripting in livewire/livewire 2024-03-19
- medium $this->validate() returns all properties, not just validated ones 2020-09-22
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.