Skip to content
Laskyr

CVE-2026-78395: Link Library missing authorization check vulnerability

medium 5.3 published 2026-10-29

Fixed in Link Library 7.10.0

Link Library older than 7.10.0 is affected by this missing authorization issue. Sites on 7.10.0 or newer are not affected; the latest release is 7.10.1.

Affected versions
older than 7.10.0
Fixed in
7.10.0
Latest version
7.10.1
Severity
Medium · CVSS 5.3
Active installs
10,000+
Type
Missing authorization check

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

What to do now

  1. Update Link Library to 7.10.0 or newer (the latest is 7.10.1): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Link Library issue. With WP-CLI: wp plugin get link-library --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Link Library WordPress plugin before 7.10.0 does not re-check the selected library's own login requirement when processing its front-end link submission, allowing unauthenticated users to submit links to a library configured to require login by reusing a form token obtained from another library that does not.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-78395.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit