Skip to content
Laskyr

league/commonmark security advisory

CVE-2026-71488: League/commonmark: Quadratic-time denial of service when parsing crafted Markdown

CVE-2026-71488 is a high-severity denial of service vulnerability in the PHP package league/commonmark (CVSS 7.5), published 6 August 2026. It is fixed in 2.9.0; earlier versions are affected. It can be exploited without an account.

high 7.5 published 2026-08-06 · updated 2026-10-24

Fixed in league/commonmark 2.9.0

This denial of service issue affects league/commonmark versions >= 0.6.0, < 2.9.0. Upgrade to the fixed version for your release line (2.9.0). The newest release, 2.10.7, is not affected.

Affected versions
>= 0.6.0, < 2.9.0
Fixed in
2.9.0
Newest release
2.10.7
Severity
High · CVSS 7.5
Type
Denial of service
CWE-407, CWE-1050
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your league/commonmark version affected?

Run composer show league/commonmark in your project, then enter the version. We check it against this and every other known league/commonmark advisory.

Who can exploit CVE-2026-71488

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Your app is only exposed if it uses the affected part of league/commonmark. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-71488 in league/commonmark

  1. Find the installed version: composer show league/commonmark. If you never required it yourself, composer why league/commonmark shows which package pulls it in.
  2. Update it: composer update league/commonmark --with-all-dependencies. You need 2.9.0 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "league/commonmark": "^2.9.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-71488.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for denial of service issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-71488 advisory

league/commonmark is a PHP library for parsing and rendering CommonMark Markdown. From 0.6.0 until 2.9.0, specially crafted Markdown lines can cause the parser to have quadratic time complexity when converting, because several parsing paths repeatedly rescan growing portions of a line to translate between character positions and byte positions, and the Autolink extension can also copy and validate the remaining line at every URL-like prefix, allowing an attacker who can submit Markdown for conversion to consume disproportionate CPU time with a comparatively small request. This issue is fixed in 2.9.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-71488. Advisory title: “league/commonmark: Quadratic-time denial of service when parsing crafted Markdown”.

References

Other league/commonmark advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit