silverstripe/framework security advisory
CVE-2026-54720: XSS attack through media embed in silverstripe/framework
CVE-2026-54720 is a medium-severity XSS vulnerability in the PHP package silverstripe/framework (CVSS 5.4), published 1 July 2026. It is fixed in 6.2.2; earlier versions are affected. It can be exploited without an account.
medium 5.4 published 2026-07-01 · updated 2026-10-25
- Affected versions
- < 6.2.2
- Fixed in
- 6.2.2
- Newest release
- 6.3.2
- Severity
- Medium · CVSS 5.4
- Type
- Cross-site scripting (XSS)
CWE-79 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your silverstripe/framework version affected?
Who can exploit CVE-2026-54720
- Access: No account. Anyone who can send a request to an app that uses the affected code.
- Interaction: A user also has to do something, such as open a link or a page the attacker prepared.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
How to fix CVE-2026-54720 in silverstripe/framework
- Find the installed version:
composer show silverstripe/framework. If you never required it yourself,composer why silverstripe/frameworkshows which package pulls it in. - Update it:
composer update silverstripe/framework --with-all-dependencies. You need 6.2.2 or newer. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"silverstripe/framework": "^6.2.2"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-54720. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Escape output in your own templates and add a Content-Security-Policy that blocks inline scripts.
- Limit who can save the content the advisory names (for example rich text, SVG or form fields).
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-54720 advisory
Silverstripe Framework is a PHP framework which powers the Silverstripe CMS. In versions prior to 6.2.2, the "Insert media from web" functionality in the CMS is vulnerable to XSS from a specially crafted embed. This issue was fixed in version 6.2.2/
References
- GitHub security advisory GHSA-gvrw-qqp5-jgc5 github.com
- Silverstripe security advisory www.silverstripe.org
Other silverstripe/framework advisories
- CVE-2026-88988: XSS via SVG data URI 2026-10-28
- SS-2026-004 - Password reset token account takeover 2026-10-28
- CVE-2026-91112: CMS_ACCESS_SecurityAdmin privilege escalation 2026-10-28
- CVE-2026-91110: XSS using control bytes 2026-10-28
- CVE-2026-88989: Auth bypass GridFieldDetailForm 2026-10-28
- CVE-2026-91115: RCE via i18nTextCollectorTask writer parameter 2026-10-28
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.