Skip to content
Laskyr

twig/twig security advisory

CVE-2026-48806: Sandbox __toString() policy bypass via dynamic mapping keys in twig/twig

CVE-2026-48806 is a medium-severity missing authorization vulnerability in the PHP package twig/twig (CVSS 9.1), published 14 July 2026. It is fixed in 3.27.0; earlier versions are affected. It can be exploited without an account.

medium 9.1 published 2026-07-14 · updated 2026-10-24

Fixed in twig/twig 3.27.0

This missing authorization issue affects twig/twig versions >= 1.0.0, < 3.27.0. Upgrade to the fixed version for your release line (3.27.0). The newest release, 3.30.0, is not affected.

Affected versions
>= 1.0.0, < 3.27.0
Fixed in
3.27.0
Newest release
3.30.0
Severity
Medium · CVSS 9.1
Type
Missing authorization check
CWE-693, CWE-863
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your twig/twig version affected?

Run composer show twig/twig in your project, then enter the version. We check it against this and every other known twig/twig advisory.

Who can exploit CVE-2026-48806

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Your app is only exposed if it uses the affected part of twig/twig. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-48806 in twig/twig

  1. Find the installed version: composer show twig/twig. If you never required it yourself, composer why twig/twig shows which package pulls it in.
  2. Update it: composer update twig/twig --with-all-dependencies. You need 3.27.0 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "twig/twig": "^3.27.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-48806.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for missing authorization issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-48806 advisory

Twig is a template language for PHP. Prior to 3.27.0, ArrayExpression does not guard dynamic mapping keys that are coerced to strings, allowing PHP to invoke __toString() on a Stringable object used as a mapping key without calling SandboxExtension::ensureToStringAllowed(). This issue is fixed in version 3.27.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-48806. Advisory title: “Sandbox __toString() policy bypass via dynamic mapping keys”.

References

Other twig/twig advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit