Skip to content
Laskyr

symfony/yaml security advisory

CVE-2026-45133: YAML Parser Stack Exhaustion via Unbounded Recursion in Nested Blocks, Sequences, and Mappings

CVE-2026-45133 is a low-severity denial of service vulnerability in the PHP package symfony/yaml (CVSS 7.5), published 14 July 2026. It is fixed in 5.4.52, 6.4.40, 7.4.12 and 8.0.12, one per release line; earlier versions on each line are affected. It can be exploited without an account.

low 7.5 published 2026-07-14 · updated 2026-07-15

Fixed in symfony/yaml 5.4.52, 6.4.40, 7.4.12 and 8.0.12

This denial of service issue affects symfony/yaml in 4 release lines: >= 2.0.0, < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12. Upgrade to the fixed version for your release line (5.4.52, 6.4.40, 7.4.12 and 8.0.12). The newest release, 8.1.10, is not affected.

Affected versions
>= 2.0.0, < 5.4.52
>= 6.0.0, < 6.4.40
>= 7.0.0, < 7.4.12
>= 8.0.0, < 8.0.12
Fixed in
5.4.52, 6.4.40, 7.4.12, 8.0.12
Newest release
8.1.10
Severity
Low · CVSS 7.5
Type
Denial of service
CWE-674, CWE-776, CWE-1333
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Also affects

The same advisory covers another package in our list. Fix whichever one your project installs.

Is your symfony/yaml version affected?

Run composer show symfony/yaml in your project, then enter the version. We check it against this and every other known symfony/yaml advisory.

Who can exploit CVE-2026-45133

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Your app is only exposed if it uses the affected part of symfony/yaml. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-45133 in symfony/yaml

  1. Find the installed version: composer show symfony/yaml. If you never required it yourself, composer why symfony/yaml shows which package pulls it in.
  2. Update it: composer update symfony/yaml --with-all-dependencies. You need the fixed version for your release line (5.4.52, 6.4.40, 7.4.12 and 8.0.12).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "symfony/yaml": "^8.0.12" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-45133.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for denial of service issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-45133 advisory

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-45133. Advisory title: “CVE-2026-45133: YAML Parser Stack Exhaustion via Unbounded Recursion in Nested Blocks, Sequences, and Mappings”.

References

Other symfony/yaml advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit