CVE-2026-42690: LearnPress missing authorization check vulnerability
medium 5.4 published 2026-10-29
- Affected versions
- 4.4.10 and older
- Fixed in
- 4.4.11
- Latest version
- 4.4.13
- Severity
- Medium · CVSS 5.4
- Active installs
- 70,000+
- Type
- Missing authorization check
What an attacker needs
- Access: A low-level account on the site, such as a subscriber or customer (per the CVSS score).
CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
What to do now
- Update LearnPress to 4.4.11 or newer (the latest is 4.4.13): Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- Not sure which version you run? Check your version against every known LearnPress issue.
With WP-CLI:
wp plugin get learnpress --field=version. - If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.
The advisory
Subscriber Broken Access Control in LearnPress <= 4.4.10 versions.
References
- NVD CVE-2026-42690 nvd.nist.gov
- Patchstack advisory patchstack.com
Related
Ran an affected version? Check your site for signs of a hack
The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.
Where this data comes from
- CVE record, score and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Versions and install counts: wordpress.org/plugins/learnpress (Plugins API), fetched 2026-11-04.
- The summary, “what an attacker needs” and “what to do” sections are our plain-English reading of the record and the plugin's release history; the quoted description is the record's own text. Spot an error? Email Daniel.