Skip to content
Laskyr

phpoffice/phpspreadsheet security advisory

CVE-2026-40902: PhpSpreadsheet has CPU Denial of Service via Unbounded Row Number in XLSX Row Dimensions

CVE-2026-40902 is a high-severity denial of service vulnerability in the PHP package phpoffice/phpspreadsheet (CVSS 7.5), published 12 May 2026. The advisory does not name a fixed version. It can be exploited without an account.

high 7.5 published 2026-05-12 · updated 2026-10-26

The advisory does not name a fixed version

This denial of service issue affects phpoffice/phpspreadsheet in 5 release lines: <= 1.30.3; >= 2.0.0, <= 2.1.15; >= 2.2.0, <= 2.4.4; >= 3.3.0, <= 3.10.4; >= 4.0.0, <= 5.6.0. The newest release (5.10.0) is outside the affected range.

Affected versions
<= 1.30.3
>= 2.0.0, <= 2.1.15
>= 2.2.0, <= 2.4.4
>= 3.3.0, <= 3.10.4
>= 4.0.0, <= 5.6.0
Fixed in
not stated
Newest release
5.10.0
Severity
High · CVSS 7.5
Type
Denial of service
CWE-770
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your phpoffice/phpspreadsheet version affected?

Run composer show phpoffice/phpspreadsheet in your project, then enter the version. We check it against this and every other known phpoffice/phpspreadsheet advisory.

Who can exploit CVE-2026-40902

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Your app is only exposed if it uses the affected part of phpoffice/phpspreadsheet. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-40902 in phpoffice/phpspreadsheet

  1. Find the installed version: composer show phpoffice/phpspreadsheet. If you never required it yourself, composer why phpoffice/phpspreadsheet shows which package pulls it in.
  2. Update it: composer update phpoffice/phpspreadsheet --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "phpoffice/phpspreadsheet": "^5.10.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-40902.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for denial of service issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-40902 advisory

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0, the XLSX reader's ColumnAndRowAttributes::readRowAttributes() method reads row numbers from XML attributes without validating them against the spreadsheet maximum row limit (AddressRange::MAX_ROW = 1,048,576). An attacker can craft a minimal XLSX file (~1.6KB) containing a <row r="999999999"/> element that inflates cachedHighestRow to 999,999,999, causing any subsequent row iteration to attempt ~1 billion loop cycles and exhaust CPU resources. This vulnerability is fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-40902. Advisory title: “PhpSpreadsheet has CPU Denial of Service via Unbounded Row Number in XLSX Row Dimensions”.

References

Other phpoffice/phpspreadsheet advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit