phpoffice/phpspreadsheet security advisory
CVE-2026-40863: PhpSpreadsheet has CPU Denial of Service via Unbounded Row Index in SpreadsheetML XML Reader
CVE-2026-40863 is a high-severity denial of service vulnerability in the PHP package phpoffice/phpspreadsheet (CVSS 7.5), published 12 May 2026. The advisory does not name a fixed version. It can be exploited without an account.
high 7.5 published 2026-05-12 · updated 2026-10-26
- Affected versions
- <= 1.30.5
>= 2.0.0, <= 2.1.15
>= 2.2.0, <= 2.4.4
>= 3.3.0, <= 3.10.4
>= 4.0.0, <= 5.6.0 - Fixed in
- not stated
- Newest release
- 5.10.0
- Severity
- High · CVSS 7.5
- Type
- Denial of service
CWE-770 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your phpoffice/phpspreadsheet version affected?
Who can exploit CVE-2026-40863
- Access: No account. Anyone who can send a request to an app that uses the affected code.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
How to fix CVE-2026-40863 in phpoffice/phpspreadsheet
- Find the installed version:
composer show phpoffice/phpspreadsheet. If you never required it yourself,composer why phpoffice/phpspreadsheetshows which package pulls it in. - Update it:
composer update phpoffice/phpspreadsheet --with-all-dependencies. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"phpoffice/phpspreadsheet": "^5.10.0"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-40863. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Rate-limit the affected endpoint and cap request body, header and upload sizes at the web server.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-40863 advisory
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0, the SpreadsheetML XML reader (Reader\Xml) does not validate the ss:Index row attribute against the maximum allowed row count (AddressRange::MAX_ROW = 1,048,576). An attacker can craft a SpreadsheetML XML file with ss:Index="999999999" on a <Row> element, which inflates the internal cachedHighestRow to ~1 billion. Any subsequent call to getRowIterator() without an explicit end row will attempt to iterate ~1 billion rows, causing CPU exhaustion and denial of service. This vulnerability is fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0.
References
- GitHub advisory GHSA-84wq-86v6-x5j6 github.com
Other phpoffice/phpspreadsheet advisories
- medium CVE-2026-108360: PhpSpreadsheet: SSRF whitelist bypass via unre-validated HTTP redirect in Drawing::setPath external image loading 2026-10-27
- high CVE-2026-108359: PhpSpreadsheet ODS Reader: Unbounded number-rows-repeated → CPU & Memory Exhaustion (DoS) 2026-10-27
- high CVE-2026-108358: PhpSpreadsheet: XmlScanner Bypass via ISO-2022 Escape Sequences Allows XXE and Denial of Service 2026-10-27
- high CVE-2026-108357: PhpSpreadsheet: XmlScanner Bypass via Double-Encoded unentity() TOCTOU Allows XXE and Denial of Service 2026-10-27
- high CVE-2026-59933: PHPSpreadsheet: XLS/OLE sector-chain self-loop causes memory exhaustion 2026-07-23
- high CVE-2026-59932: PHPSpreadsheet: Gnumeric reader unbounded gzip expansion causes memory exhaustion 2026-07-23
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.